summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Ziemba2018-09-02 05:32:38 -0400
committerDan Ziemba2018-09-02 09:32:03 -0400
commit01b8bd8572dadf03a4fae08480beb1796708fa65 (patch)
treecbe5efe4b6c73e87c5e648c31551cbc3e34a71c2
parentf4cb332d70cea8c138b4b9cc666be939815130dc (diff)
downloadaur-01b8bd8572dadf03a4fae08480beb1796708fa65.tar.gz
Removed ffmpeg patch
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD10
-rw-r--r--fix-ffmpeg.patch13
3 files changed, 8 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dfc5272e5533..7f7d60c16d59 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tvheadend-git
pkgdesc = TV streaming server for Linux
- pkgver = 4.3.r1252.g595fd174f
- pkgrel = 5
+ pkgver = 4.3.r1292.g9b9ee6859
+ pkgrel = 1
url = https://tvheadend.org/
install = tvheadend.install
arch = i686
@@ -14,13 +14,13 @@ pkgbase = tvheadend-git
makedepends = git
makedepends = python
depends = avahi
- depends = openssl
- depends = uriparser
depends = ffmpeg
- depends = pcre2
- depends = libfdk-aac
depends = libdvbcsa
+ depends = libfdk-aac
depends = libhdhomerun
+ depends = openssl
+ depends = pcre2
+ depends = uriparser
optdepends = xmltv: For an alternative source of programme listings
provides = tvheadend
conflicts = tvheadend
@@ -30,10 +30,8 @@ pkgbase = tvheadend-git
backup = etc/conf.d/tvheadend
source = tvheadend-git::git+https://github.com/tvheadend/tvheadend.git#branch=master
source = dvb-scan-tables::git+https://github.com/tvheadend/dtv-scan-tables.git#branch=tvheadend
- source = fix-ffmpeg.patch
md5sums = SKIP
md5sums = SKIP
- md5sums = 2caa4893574ebb6c7f672e2313df865b
pkgname = tvheadend-git
diff --git a/PKGBUILD b/PKGBUILD
index a2fc397f046f..92b6122bd749 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgname=tvheadend-git
_gitname='tvheadend-git'
-pkgver=4.3.r1252.g595fd174f
-pkgrel=5
+pkgver=4.3.r1292.g9b9ee6859
+pkgrel=1
pkgdesc="TV streaming server for Linux"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://tvheadend.org/"
@@ -34,12 +34,10 @@ backup=('etc/conf.d/tvheadend')
source=(
"${_gitname}::git+https://github.com/tvheadend/tvheadend.git#branch=master"
'dvb-scan-tables::git+https://github.com/tvheadend/dtv-scan-tables.git#branch=tvheadend'
- 'fix-ffmpeg.patch'
)
md5sums=(
'SKIP'
'SKIP'
- '2caa4893574ebb6c7f672e2313df865b'
)
pkgver() {
@@ -54,10 +52,6 @@ prepare() {
cp -a "dvb-scan-tables" "${_dvbscan}"
rm -rf "${_dvbscan}/.git"
touch "${_dvbscan}/.stamp"
-
- # Fix changed constant name in ffmpeg
- cd "${srcdir}/${_gitname}"
- patch -p1 -i "${srcdir}/fix-ffmpeg.patch"
}
build() {
diff --git a/fix-ffmpeg.patch b/fix-ffmpeg.patch
deleted file mode 100644
index bdff6476a96e..000000000000
--- a/fix-ffmpeg.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/transcoding/codec/codec.c b/src/transcoding/codec/codec.c
-index 54d7dc2a7..9a8598b03 100644
---- a/src/transcoding/codec/codec.c
-+++ b/src/transcoding/codec/codec.c
-@@ -102,7 +102,7 @@ codec_get_title(AVCodec *self)
- str_snprintf(codec_title, sizeof(codec_title),
- self->long_name ? "%s: %s%s" : "%s%s%s",
- self->name, self->long_name ? self->long_name : "",
-- (self->capabilities & CODEC_CAP_EXPERIMENTAL) ? " (Experimental)" : "")
-+ (self->capabilities & AV_CODEC_CAP_EXPERIMENTAL) ? " (Experimental)" : "")
- ) {
- return NULL;
- }