summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCédric Schieli2020-04-12 18:33:03 +0200
committerCédric Schieli2020-04-12 18:33:03 +0200
commit7ecf358d56a432752bc8bb47508fe9553af00ec8 (patch)
tree8fa89650f0d80ba4894f9993fc320dc4e0dbda56
parent8f60ee2a8852d4e629476863aa9f3279acb4bd63 (diff)
downloadaur-7ecf358d56a432752bc8bb47508fe9553af00ec8.tar.gz
Split configuration file out of PKGBUILD
-rw-r--r--PKGBUILD16
-rw-r--r--tvheadend.conf4
2 files changed, 9 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 013d52f73506..6d4e0bb32595 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,11 +25,11 @@ backup=('etc/conf.d/tvheadend')
source=(
"${_gitname}::git+https://github.com/tvheadend/tvheadend.git#branch=master"
'dvb-scan-tables::git+https://git.linuxtv.org/dtv-scan-tables.git#branch=master'
+ 'tvheadend.conf'
)
-md5sums=(
- 'SKIP'
- 'SKIP'
-)
+md5sums=('SKIP'
+ 'SKIP'
+ '2dfcd6632de3862e79aa258f7f0f64fb')
pkgver() {
cd "${srcdir}/${_gitname}"
@@ -110,12 +110,6 @@ package() {
sed -i 's|/etc/sysconfig|/etc/conf.d|g' \
"$pkgdir/usr/lib/systemd/system/tvheadend.service"
- install -d "$pkgdir/etc/conf.d"
- cat << EOF > "$pkgdir/etc/conf.d/tvheadend"
-# Configuration file for the tvheadend service.
-
-MALLOC_ARENA_MAX=4
-OPTIONS="-u hts -g video -6 --http_port 9981 --htsp_port 9982"
-EOF
+ install -D -m 644 "$srcdir/tvheadend.conf" "$pkgdir/etc/conf.d/tvheadend"
}
diff --git a/tvheadend.conf b/tvheadend.conf
new file mode 100644
index 000000000000..de838759c988
--- /dev/null
+++ b/tvheadend.conf
@@ -0,0 +1,4 @@
+# Configuration file for the tvheadend service.
+
+MALLOC_ARENA_MAX=4
+OPTIONS="-u hts -g video -6 --http_port 9981 --htsp_port 9982"