summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCédric Schieli2020-04-12 17:48:54 +0200
committerCédric Schieli2020-04-12 18:38:40 +0200
commitedbdb69c536d3177f99965ab31fa8ec59ee32ed9 (patch)
tree37210f836d4e93e43cff59130565110c4393968b
parent2b8c031c02eec6d68c2c8cea85fe098b2ca818bf (diff)
downloadaur-edbdb69c536d3177f99965ab31fa8ec59ee32ed9.tar.gz
Enable dbus support
-rw-r--r--PKGBUILD10
-rw-r--r--tvheadend-dbus.conf16
-rw-r--r--tvheadend.conf2
3 files changed, 25 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2eda3cbb6ab3..1a702381c4c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,6 +9,7 @@ arch=('i686' 'pentium4' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://tvheadend.org/"
license=('GPL3')
depends=(
+ 'dbus'
'openssl'
'pcre2'
'uriparser'
@@ -26,10 +27,12 @@ source=(
"${_gitname}::git+https://github.com/tvheadend/tvheadend.git#branch=master"
'dvb-scan-tables::git+https://git.linuxtv.org/dtv-scan-tables.git#branch=master'
'tvheadend.conf'
+ 'tvheadend-dbus.conf'
)
md5sums=('SKIP'
'SKIP'
- '2e80ac965a4e730a79dec65db4f6e67d')
+ '57185c43bcd3512296cb23c849f4b872'
+ '67222bc49a82fab4189083cf993fa659')
pkgver() {
cd "${srcdir}/${_gitname}"
@@ -89,7 +92,7 @@ build() {
--disable-bundle \
--disable-pngquant \
--disable-kqueue \
- --disable-dbus_1 \
+ --enable-dbus_1 \
--disable-android \
--disable-gtimer_check \
--disalbe-slow_memoryinfo \
@@ -111,5 +114,8 @@ package() {
"$pkgdir/usr/lib/systemd/system/tvheadend.service"
install -D -m 644 "$srcdir/tvheadend.conf" "$pkgdir/etc/conf.d/tvheadend"
+
+ install -D -m 644 "$srcdir/tvheadend-dbus.conf" \
+ "$pkgdir/usr/share/dbus-1/system.d/tvheadend.conf"
}
diff --git a/tvheadend-dbus.conf b/tvheadend-dbus.conf
new file mode 100644
index 000000000000..07a5363b921c
--- /dev/null
+++ b/tvheadend-dbus.conf
@@ -0,0 +1,16 @@
+<!DOCTYPE busconfig PUBLIC
+ "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
+ "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
+<busconfig>
+
+ <policy user="hts">
+ <allow own="org.tvheadend.server"/>
+ <allow own="org.tvheadend.notify"/>
+ </policy>
+
+ <policy group="hts">
+ <allow send_destination="org.tvheadend.server"/>
+ <allow receive_sender="org.tvheadend.server"/>
+ </policy>
+
+</busconfig>
diff --git a/tvheadend.conf b/tvheadend.conf
index 08078841cadc..ef00be1892de 100644
--- a/tvheadend.conf
+++ b/tvheadend.conf
@@ -1,4 +1,4 @@
# Configuration file for the tvheadend service.
MALLOC_ARENA_MAX=4
-OPTIONS="-u hts -g video -6 --http_port 9981 --htsp_port 0"
+OPTIONS="-u hts -g video -6 --http_port 9981 --htsp_port 0 --dbus"