summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Ziemba2016-04-22 20:45:57 -0400
committerDan Ziemba2016-04-22 20:45:57 -0400
commitfe486eda276a8fd46adc8b5a1c7d19ead73c77b6 (patch)
treead2a0e6e269f33e9cc2d260f9ad2c204bfc5f749
parent001a8638053c86d324e0e66db9861836774a3ad2 (diff)
downloadaur-fe486eda276a8fd46adc8b5a1c7d19ead73c77b6.tar.gz
Now using tvh provided systemd service file.
You can now configure arguments in /etc/conf.d/tvheadend.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD22
-rw-r--r--tvheadend.service14
3 files changed, 18 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 84e2227086c8..5c9a1263c208 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Apr 6 20:37:09 UTC 2016
+# Sat Apr 23 00:44:47 UTC 2016
pkgbase = tvheadend-git
pkgdesc = TV streaming server for Linux
- pkgver = 4.1.r1834.g957b835
+ pkgver = 4.1.r1931.gc3eefc6
pkgrel = 1
url = https://tvheadend.org/
install = tvheadend.install
@@ -25,12 +25,11 @@ pkgbase = tvheadend-git
conflicts = hts-tvheadend
conflicts = hts-tvheadend-svn
conflicts = tvheadend-git
+ backup = etc/conf.d/tvheadend
source = tvheadend-git::git+https://github.com/tvheadend/tvheadend.git#branch=master
source = dvb-scan-tables::git+https://github.com/tvheadend/dtv-scan-tables.git#branch=tvheadend
- source = tvheadend.service
md5sums = SKIP
md5sums = SKIP
- md5sums = b546f4486f0d28bea13ad1fb676acb27
pkgname = tvheadend-git
diff --git a/PKGBUILD b/PKGBUILD
index 4098ed7dc352..6789447b6502 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=tvheadend-git
_gitname='tvheadend-git'
-pkgver=4.1.r1834.g957b835
+pkgver=4.1.r1931.gc3eefc6
pkgrel=1
pkgdesc="TV streaming server for Linux"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
@@ -18,14 +18,12 @@ optdepends=('xmltv: For an alternative source of programme listings')
provides=('tvheadend')
conflicts=('tvheadend' 'hts-tvheadend' 'hts-tvheadend-svn' 'tvheadend-git')
install=tvheadend.install
+backup=('etc/conf.d/tvheadend')
source=("${_gitname}::git+https://github.com/tvheadend/tvheadend.git#branch=master"
- "dvb-scan-tables::git+https://github.com/tvheadend/dtv-scan-tables.git#branch=tvheadend"
- 'tvheadend.service')
-
+ "dvb-scan-tables::git+https://github.com/tvheadend/dtv-scan-tables.git#branch=tvheadend")
md5sums=('SKIP'
- 'SKIP'
- 'b546f4486f0d28bea13ad1fb676acb27')
+ 'SKIP')
pkgver() {
cd "${srcdir}/${_gitname}"
@@ -60,7 +58,17 @@ build() {
package() {
cd "${srcdir}/${_gitname}"
make DESTDIR="$pkgdir/" install
- install -D -m 644 "$srcdir/tvheadend.service" \
+
+ install -D -m 644 "${srcdir}/${_gitname}/rpm/tvheadend.service" \
"$pkgdir/usr/lib/systemd/system/tvheadend.service"
+ sed -i 's|/etc/sysconfig|/etc/conf.d|g' "$pkgdir/usr/lib/systemd/system/tvheadend.service"
+
+ install -d "$pkgdir/etc/conf.d"
+ cat << EOF > "$pkgdir/etc/conf.d/tvheadend"
+# Configuration file for the tvheadend service.
+
+MALLOC_ARENA_MAX=4
+OPTIONS="-u hts -g video -6 --http_port 9981 --htsp_port 9982"
+EOF
}
diff --git a/tvheadend.service b/tvheadend.service
deleted file mode 100644
index 5754f27d20a0..000000000000
--- a/tvheadend.service
+++ /dev/null
@@ -1,14 +0,0 @@
-[Unit]
-Description=tvheadend
-After=tmp.mount network.target
-
-[Service]
-Type=forking
-PIDFile=/run/tvheadend.pid
-ExecStart=/usr/bin/tvheadend -f -p /run/tvheadend.pid -C -u hts -g video
-ExecStop=/usr/bin/rm /run/tvheadend.pid
-Restart=always
-RestartSec=5
-
-[Install]
-WantedBy=multi-user.target