summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCraig Barnes2018-05-11 15:21:59 +0100
committerCraig Barnes2018-05-11 15:21:59 +0100
commit593a940ddca74e04c3d0d5b32b7637f4c455eadd (patch)
tree14e74593ceca286d557ce539f103f8525bdea51a
parent2e6b7c0f26ebad4344d04608c770261b54f1f426 (diff)
downloadaur-593a940ddca74e04c3d0d5b32b7637f4c455eadd.tar.gz
Add workaround for buggy upstream Makefile not using $LDFLAGS
Also remove "gcc" and "make" from makedepends. They're both in the base-devel group and don't need to be mentioned explicitly.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 4 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b2364215065f..b815e0c057e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,11 @@
pkgbase = tweak-hexeditor
pkgdesc = Efficient command line hex editor
pkgver = 3.02
- pkgrel = 3
+ pkgrel = 4
url = https://www.chiark.greenend.org.uk/~sgtatham/tweak/
arch = i686
arch = x86_64
license = MIT
- makedepends = make
- makedepends = gcc
depends = ncurses
depends = glibc
source = https://www.chiark.greenend.org.uk/~sgtatham/tweak/tweak-3.02.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 192a588df575..b064fa584fd0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,10 +4,9 @@
pkgname=tweak-hexeditor
pkgdesc='Efficient command line hex editor'
pkgver=3.02
-pkgrel=3
+pkgrel=4
arch=('i686' 'x86_64')
depends=('ncurses' 'glibc')
-makedepends=('make' 'gcc')
url='https://www.chiark.greenend.org.uk/~sgtatham/tweak/'
license=('MIT')
source=("https://www.chiark.greenend.org.uk/~sgtatham/tweak/tweak-$pkgver.tar.gz")
@@ -18,8 +17,8 @@ sha256sums=('5b4c19b1bf8734d1623e723644b8da58150b882efa9f23bbe797c3922f295a1a')
build() {
cd "tweak-$pkgver"
# The upstream Makefile is very poorly implemented and doesn't pick
- # up CFLAGS or CPPFLAGS from the environment.
- make XFLAGS="$CPPFLAGS $CFLAGS"
+ # up CFLAGS, CPPFLAGS or LDFLAGS from the environment.
+ make XFLAGS="$CPPFLAGS $CFLAGS" LINK="gcc $LDFLAGS"
}
package() {