summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCraig Barnes2017-04-09 22:44:40 +0100
committerCraig Barnes2017-04-09 22:44:40 +0100
commit9a3f3a26cd895716ca8e707ebeded9aa6ebc62e5 (patch)
tree59e77900f33be5a67006a8f6943bf3efc1b5be53
parent20c5d29b0988134525344b66bfbeeee1ac185ef3 (diff)
downloadaur-9a3f3a26cd895716ca8e707ebeded9aa6ebc62e5.tar.gz
Update to 3.02 release
Also: * Change license from "custom" to "MIT" * Use proper upstream tarball URL instead of obscure Debian mirror * Drop pointless sed pre-processing of Makefile and just pass variable overrides via the command line * Install the LICENSE file * Update md5sums, add sha1sums * Add myself as a package maintainer
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD28
2 files changed, 21 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26be7bb01b88..e02ca87c8bd6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = tweak-hexeditor
- pkgdesc = Efficient Command Line hex editor
- pkgver = 3.01
+ pkgdesc = Efficient command line hex editor
+ pkgver = 3.02
pkgrel = 1
url = http://www.chiark.greenend.org.uk/~sgtatham/tweak
arch = i686
arch = x86_64
- license = custom
+ license = MIT
makedepends = make
makedepends = gcc
depends = ncurses
depends = glibc
- source = http://mirrors.163.com/debian/pool/main/t/tweak/tweak_3.01.orig.tar.gz
- md5sums = 3ae8db9fd482b679835a80c4635f71be
+ source = http://www.chiark.greenend.org.uk/~sgtatham/tweak/tweak-3.02.tar.gz
+ md5sums = d50e20d9ed05d7cc5eb04ff3f0bf1d9b
+ sha1sums = 619c2dcb54dfbbff89576d6b34d5483a8642e635
pkgname = tweak-hexeditor
diff --git a/PKGBUILD b/PKGBUILD
index caa595edc33c..30fc38225b31 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,27 @@
-#Contributor: Leon Belmont <meow AT linux DOT cn>
+# Maintainer: Craig Barnes <cr@igbarn.es>
+# Contributor: Leon Belmont <meow AT linux DOT cn>
pkgname=tweak-hexeditor
_pkgname=tweak
-pkgdesc="Efficient Command Line hex editor"
-pkgver=3.01
+pkgdesc='Efficient command line hex editor'
+pkgver=3.02
pkgrel=1
arch=('i686' 'x86_64')
depends=('ncurses' 'glibc')
makedepends=('make' 'gcc')
-url=http://www.chiark.greenend.org.uk/~sgtatham/tweak
-license=('custom')
-source=("http://mirrors.163.com/debian/pool/main/t/tweak/${_pkgname}_${pkgver}.orig.tar.gz")
-md5sums=('3ae8db9fd482b679835a80c4635f71be')
-
+url='http://www.chiark.greenend.org.uk/~sgtatham/tweak'
+license=('MIT')
+source=("http://www.chiark.greenend.org.uk/~sgtatham/tweak/tweak-$pkgver.tar.gz")
+md5sums=('d50e20d9ed05d7cc5eb04ff3f0bf1d9b')
+sha1sums=('619c2dcb54dfbbff89576d6b34d5483a8642e635')
build() {
- cd "$srcdir/$_pkgname-$pkgver"
- sed -ri 's@^(PREFIX=).*$@\1"'${pkgdir}'/usr"@' Makefile
- make
+ cd "tweak-$pkgver"
+ make
}
+
package() {
- cd "$srcdir/$_pkgname-$pkgver"
- make install
+ cd "tweak-$pkgver"
+ make install PREFIX="$pkgdir/usr" MANDIR="$pkgdir/usr/share/man/man1"
+ install -Dm 644 LICENCE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}