summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlibele2021-07-28 14:01:58 -0500
committerlibele2021-07-28 14:01:58 -0500
commit44ad3b2326874e56cb20fc9083d174862e8e0d96 (patch)
treebdf1892cf6d4cb5aa2702ab92c7595854ff80c5a
downloadaur-44ad3b2326874e56cb20fc9083d174862e8e0d96.tar.gz
version 2.1.1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..319d866c7745
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = tweego-bin
+ pkgdesc = a command line compiler for Twine/Twee story formats, written in Go.
+ pkgver = 2.1.1
+ pkgrel = 1
+ url = https://www.motoslave.net/tweego
+ arch = i686
+ arch = x86_64
+ license = BSD
+ license = custom
+ provides = tweego
+ conflicts = tweego
+ source_i686 = https://github.com/tmedwards/tweego/releases/download/v2.1.1/tweego-2.1.1-linux-x86.zip
+ md5sums_i686 = 99155762268a8b89868de8dfed3dcb0f
+ source_x86_64 = https://github.com/tmedwards/tweego/releases/download/v2.1.1/tweego-2.1.1-linux-x64.zip
+ md5sums_x86_64 = 6ebec69142cc6aa9501b82b141da04cc
+
+pkgname = tweego-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..56890e0159d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# maintainer: libele <libele@disroot.org>
+
+pkgname=tweego-bin
+_binpkg=tweego
+pkgver=2.1.1
+pkgrel=1
+pkgdesc="a command line compiler for Twine/Twee story formats, written in Go."
+arch=('i686' 'x86_64')
+url='https://www.motoslave.net/tweego'
+license=('BSD' 'custom')
+provides=('tweego')
+conflicts=('tweego')
+source_i686=("https://github.com/tmedwards/tweego/releases/download/v${pkgver}/tweego-${pkgver}-linux-x86.zip")
+source_x86_64=("https://github.com/tmedwards/tweego/releases/download/v${pkgver}/tweego-${pkgver}-linux-x64.zip")
+md5sums_i686=('99155762268a8b89868de8dfed3dcb0f')
+md5sums_x86_64=('6ebec69142cc6aa9501b82b141da04cc')
+
+package() {
+ cd "${srcdir}"
+ install -dm755 "${pkgdir}/usr/bin"
+ install -Dm755 tweego "${pkgdir}/usr/share/${_binpkg}/${_binpkg}"
+
+ ln -s "/usr/share/${_binpkg}/${_binpkg}" "${pkgdir}/usr/bin/${_binpkg}"
+ cp -a storyformats "${pkgdir}/usr/share/${_binpkg}"
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${_binpkg}/LICENSE"
+ cp -a licenses "${pkgdir}/usr/share/licenses/${_binpkg}"
+}