summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsyui2018-06-14 20:04:46 +0900
committersyui2018-06-14 20:04:46 +0900
commitf1b35141cc7a12c382fd8944d97919dc45506742 (patch)
treeba7f49b1824fb6411ee5470c788ac5e5d214b5aa
parent7c412a997c920817e70a354ad065dd5fe5a60fdc (diff)
downloadaur-f1b35141cc7a12c382fd8944d97919dc45506742.tar.gz
test
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b80389fff3b4..3a7f471841b3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,13 +7,10 @@ pkgbase = twg
arch = i686
license = MIT
noextract = https://github.com/syui/twg/releases/download/0.2/linux_386_twg
- noextract = https://github.com/syui/twg/releases/download/0.2/linux_amd64_twg
options = !strip
options = !emptydirs
source = https://github.com/syui/twg/releases/download/0.2/linux_386_twg
- source = https://github.com/syui/twg/releases/download/0.2/linux_amd64_twg
sha1sums = e7202e10d958e1a9ab893fe24765317b18e12609
- sha1sums = d0de749db19bceb7fbc9212c42e8ecf9a355bc27
pkgname = twg
diff --git a/PKGBUILD b/PKGBUILD
index c6b9ca441a3d..daa4b8f4ae06 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,10 +7,18 @@ arch=('x86_64' 'i686')
url="https://github.com/syui/twg"
options=('!strip' '!emptydirs')
license=('MIT')
-source=("$url/releases/download/$pkgver/linux_386_$pkgname"
- "$url/releases/download/$pkgver/linux_amd64_$pkgname")
+if [ "`uname -m`" = "x86_64" ];then
+ source=("$url/releases/download/$pkgver/linux_386_$pkgname")
+ sha1sums=('e7202e10d958e1a9ab893fe24765317b18e12609')
+fi
+if [ "`uname -m`" = "i684" ];then
+ source=("$url/releases/download/$pkgver/linux_amd64_$pkgname")
+ sha1sums=('d0de749db19bceb7fbc9212c42e8ecf9a355bc27')
+fi
noextract=(${source[@]%%::*})
-sha1sums=('e7202e10d958e1a9ab893fe24765317b18e12609' 'd0de749db19bceb7fbc9212c42e8ecf9a355bc27')
+build() {
+ :
+}
package() {
mkdir -p ${srcdir}/${pkgname}-${pkgver}
cd "${srcdir}/${pkgname}-${pkgver}"