summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormisson200002018-07-19 21:04:50 -0700
committermisson200002018-07-19 21:04:50 -0700
commitfbc86cbc6e4fe93f4d8708797624f7a2688399f3 (patch)
treec3f89c18db66a1823d90eee6397cab31b2171e8c
downloadaur-fbc86cbc6e4fe93f4d8708797624f7a2688399f3.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD37
-rw-r--r--twib.install11
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a97fe61e28a6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = twib-git
+ pkgdesc = Twili debug monitor bridge client and daemon
+ pkgver = r75.ea97589
+ pkgrel = 1
+ url = https://github.com/misson20000/twili
+ install = twib.install
+ arch = any
+ license = ISC
+ makedepends = git
+ makedepends = gcc
+ makedepends = cmake
+ makedepends = make
+ depends = libusb
+ depends = systemd
+ provides = twib
+ source = git+https://github.com/misson20000/twili.git
+ md5sums = SKIP
+
+pkgname = twib-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c144b491214a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: misson20000 <xenotoad at xenotoad dot n e t>
+pkgname=twib-git
+pkgver=r75.ea97589
+pkgrel=1
+pkgdesc="Twili debug monitor bridge client and daemon"
+arch=("any")
+url="https://github.com/misson20000/twili"
+license=("ISC")
+depends=("libusb" "systemd")
+makedepends=("git" "gcc" "cmake" "make")
+provides=("twib")
+source=("git+https://github.com/misson20000/twili.git")
+md5sums=("SKIP")
+install="twib.install"
+
+pkgver() {
+ cd "$srcdir/twili"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/twili"
+ git submodule update --init --recursive
+}
+
+build() {
+ cd "$srcdir/twili/twib"
+ mkdir build
+ cd build
+ cmake -G "Unix Makefiles" .. -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DWITH_SYSTEMD=ON
+ make
+}
+
+package() {
+ cd "$srcdir/twili/twib/build"
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/twib.install b/twib.install
new file mode 100644
index 000000000000..c01ced9553f1
--- /dev/null
+++ b/twib.install
@@ -0,0 +1,11 @@
+post_install() {
+ echo "enabling twibd.socket unit..."
+ systemctl enable --now twibd.socket
+}
+
+
+pre_remove() {
+ echo "disabling twibd units"
+ systemctl disable --now twibd.socket
+ systemctl disable --now twibd.service
+}