summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Cuche2024-01-26 19:04:41 +0100
committerMike Cuche2024-01-26 19:04:41 +0100
commit36f94f0eef1c97e75fa49d67ab1cb879dd2a33a5 (patch)
treedf80ae70563185825ddddde5fb37f2dc7190abeb
parent63ebf5da74d491673103fbf18d1ea9d6f93fa77f (diff)
downloadaur-36f94f0eef1c97e75fa49d67ab1cb879dd2a33a5.tar.gz
Updated dependencies to python3
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD19
2 files changed, 10 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1485cefbca5e..aa2d7f1dbdd6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = twik-git
pkgdesc = A commandline hash-based password generator
- pkgver = r42.d3403e7
+ pkgver = r52.004a764
pkgrel = 1
- url = http://gustavomondron.github.io/twik/
+ url = https://github.com/coxande/Twik
arch = any
license = GPL
makedepends = git
- makedepends = python2-setuptools
- depends = python2
+ makedepends = python-setuptools
+ depends = python
source = git+https://github.com/coxande/Twik
sha512sums = SKIP
pkgname = twik-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 66aa23f40f4d..7f9682c35865 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
-# Maintainer: Michele Bovo <mbovo@gmx.com>
+# Maintainer: Mike Cuche <cuche@mailbox.org>
pkgname='twik-git'
-pkgver=r42.d3403e7
+pkgver=r52.004a764
pkgrel=1
pkgdesc="A commandline hash-based password generator"
-url="http://gustavomondron.github.io/twik/"
+url="https://github.com/coxande/Twik"
arch=('any')
license=('GPL')
-depends=('python2')
-makedepends=('git' 'python2-setuptools')
+depends=('python')
+makedepends=('git' 'python-setuptools')
source=('git+https://github.com/coxande/Twik')
sha512sums=('SKIP')
@@ -17,15 +17,8 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare () {
- cd Twik/twik
- sed -i 's#usr/bin/python#usr/bin/python2#' twik.py
- sed -i 's#usr/bin/python#usr/bin/python2#' run.py
- sed -i 's#usr/bin/python#usr/bin/python2#' util.py
-
-}
package() {
cd Twik
- python2 setup.py install --optimize=1 --root="$pkgdir/"
+ python setup.py install --optimize=1 --root="$pkgdir/"
}