summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichele2015-06-08 19:31:25 +0200
committerMichele2015-06-08 19:31:25 +0200
commit63ebf5da74d491673103fbf18d1ea9d6f93fa77f (patch)
tree533e18c5399b79d3e523d4a2774518f2ea392595
downloadaur-63ebf5da74d491673103fbf18d1ea9d6f93fa77f.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1485cefbca5e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = twik-git
+ pkgdesc = A commandline hash-based password generator
+ pkgver = r42.d3403e7
+ pkgrel = 1
+ url = http://gustavomondron.github.io/twik/
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = python2-setuptools
+ depends = python2
+ source = git+https://github.com/coxande/Twik
+ sha512sums = SKIP
+
+pkgname = twik-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..66aa23f40f4d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Michele Bovo <mbovo@gmx.com>
+
+pkgname='twik-git'
+pkgver=r42.d3403e7
+pkgrel=1
+pkgdesc="A commandline hash-based password generator"
+url="http://gustavomondron.github.io/twik/"
+arch=('any')
+license=('GPL')
+depends=('python2')
+makedepends=('git' 'python2-setuptools')
+source=('git+https://github.com/coxande/Twik')
+sha512sums=('SKIP')
+
+pkgver() {
+ cd Twik
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare () {
+ cd Twik/twik
+ sed -i 's#usr/bin/python#usr/bin/python2#' twik.py
+ sed -i 's#usr/bin/python#usr/bin/python2#' run.py
+ sed -i 's#usr/bin/python#usr/bin/python2#' util.py
+
+}
+
+package() {
+ cd Twik
+ python2 setup.py install --optimize=1 --root="$pkgdir/"
+}