summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Griffis2017-10-18 07:20:45 -0700
committerEric Griffis2017-10-18 07:20:45 -0700
commit94b9ab932946995cac5eb4981774e065516e08d4 (patch)
tree42af7cb2a95096456786f9ffade7732606eb558e
parent04289ac07592da71b215a37e5a5663d51a2103ca (diff)
downloadaur-94b9ab932946995cac5eb4981774e065516e08d4.tar.gz
add desktop entry and SVG icon
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--twinejs.desktop8
3 files changed, 24 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c3ffb65d60e9..aa10c2ea18d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,17 @@
pkgbase = twinejs-standalone
pkgdesc = an open-source tool for telling interactive, nonlinear stories
pkgver = 2.1.3
- pkgrel = 1
+ pkgrel = 2
url = http://twinery.org/
arch = x86_64
license = GPL3
options = !strip
source = https://bitbucket.org/klembot/twinejs/downloads/twine_2.1.3_linux64.zip
+ source = http://twinery.org/homepage/img/logo.svg
+ source = twinejs.desktop
md5sums = 1ff968c4a9697ca0f0988917f2be889b
+ md5sums = c7119a1fb9d65014691b77778e5e5ec7
+ md5sums = 71705539c71923a8464240a8cb3e567f
pkgname = twinejs-standalone
diff --git a/PKGBUILD b/PKGBUILD
index a0be04ba017e..6c51a199b168 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,17 @@
# Maintainer: Eric Griffis <dedbox at gmail dot com>
pkgname=twinejs-standalone
pkgver=2.1.3
-pkgrel=1
+pkgrel=2
pkgdesc="an open-source tool for telling interactive, nonlinear stories"
arch=('x86_64')
url="http://twinery.org/"
license=('GPL3')
-source=("https://bitbucket.org/klembot/twinejs/downloads/twine_${pkgver}_linux64.zip")
-md5sums=('1ff968c4a9697ca0f0988917f2be889b')
+source=("https://bitbucket.org/klembot/twinejs/downloads/twine_${pkgver}_linux64.zip"
+ "http://twinery.org/homepage/img/logo.svg"
+ "twinejs.desktop")
+md5sums=('1ff968c4a9697ca0f0988917f2be889b'
+ 'c7119a1fb9d65014691b77778e5e5ec7'
+ '71705539c71923a8464240a8cb3e567f')
options=(!strip)
prepare() {
@@ -15,8 +19,12 @@ prepare() {
}
package() {
+ mkdir -p "$pkgdir/usr/share/applications"
+ mkdir -p "$pkgdir/usr/share/icons/hicolor/scalable/apps"
mkdir -p "$pkgdir/usr/bin"
mkdir -p "$pkgdir/opt"
cp -r "${pkgname}_${pkgver}_linux64" "$pkgdir/opt"
+ cp twinejs.desktop "$pkgdir/usr/share/applications"
+ cp logo.svg "$pkgdir/usr/share/icons/hicolor/scalable/apps/twinejs.svg"
ln -s "/opt/${pkgname}_${pkgver}_linux64/Twine" "$pkgdir/usr/bin/Twine"
}
diff --git a/twinejs.desktop b/twinejs.desktop
new file mode 100644
index 000000000000..1aa9be73cd98
--- /dev/null
+++ b/twinejs.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Encoding=UTF-8
+Name=Twine
+Comment=An open-source tool for telling interactive, nonlinear stories
+Exec=Twine
+Icon=twinejs
+Terminal=false