summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortheguy2021-02-11 11:26:29 +0100
committertheguy2021-02-11 11:26:29 +0100
commitab5b62f58b2b6781a9abf828babe127d4a25b646 (patch)
tree059f2b93978226bb9bd6fba602a1122a69fb78b6
downloadaur-ab5b62f58b2b6781a9abf828babe127d4a25b646.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bbc443fe78f1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = twint-git
+ pkgdesc = An advanced Twitter scraping & OSINT tool. (git version)
+ pkgver = 20200426.d9d0d68
+ pkgrel = 1
+ url = https://github.com/twintproject/twint
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ conflicts = twint
+ source = twint-git::git+https://github.com/twintproject/twint.git
+ sha256sums = SKIP
+
+pkgname = twint-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fdf24c7a1690
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: theguy147 <yakamoz147 (at) protonmail (dot) com>
+# Maintainer: Marco A Rojas <marco.rojas@zentek.com.mx>
+
+pkgname=twint-git
+pkgver=20200426.d9d0d68
+pkgrel=1
+pkgdesc="An advanced Twitter scraping & OSINT tool. (git version)"
+url="https://github.com/twintproject/twint"
+makedepends=('python-setuptools')
+license=('MIT')
+conflicts=('twint')
+arch=('any')
+source=("$pkgname::git+https://github.com/twintproject/twint.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pgkname"
+ git log -1 --format=%cd.%h --date=short|tr -d -
+}
+
+build() {
+ cd "$pkgname"
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}