summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgameslayer2020-07-26 21:46:46 +1000
committergameslayer2020-07-26 21:46:46 +1000
commitadfd5188b8c496e053920a6614d0d998878f52e3 (patch)
tree0d6d2a0f83f92df70598ba0a76dacc6803291792
parent4bb742d4df42368bcee31cde28c8e1490058943c (diff)
downloadaur-adfd5188b8c496e053920a6614d0d998878f52e3.tar.gz
PKGBUILD FIX #2
-Some issue adjusting to changes but I tested and got it all working :P
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 01b9e2bf9d96..3dc0f5ea1ce7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,18 @@ _pkgname=Twitch
pkgver=1.0.2
pkgrel=1
pkgdesc="Unofficial Twitch desktop application."
-arch=('any')
-url="https://gitlab.com/coreybruce/twitch-desktop"
+arch=('x86_64')
+url="https://gitlab.com/twitch-application/application"
license=('GPL')
depends=('nss' 'gtk3' 'libxss')
makedepends=('npm' 'git' 'unzip')
provides=("${pkgname%}")
conflicts=("${pkgname%}")
-source=('git+https://gitlab.com/coreybruce/twitch-desktop.git')
+source=('git+https://gitlab.com/twitch-application/application.git')
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/$pkgname-desktop"
+ cd "$srcdir/application"
node -pe "require('./package.json').version"
}
@@ -36,7 +36,7 @@ package() {
ln -s "/opt/$_pkgname/$_pkgname" "$pkgdir/usr/bin/${pkgname%}"
# Desktop Entry
- install -Dm644 "$srcdir/$pkgname-desktop/$_pkgname.desktop" \
+ install -Dm644 "$srcdir/application/$_pkgname.desktop" \
"$pkgdir/usr/share/applications/$_pkgname.desktop"
sed -i s%/usr/share%/opt% "$pkgdir/usr/share/applications/$_pkgname.desktop"
}