summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzneix2021-05-11 13:49:12 +0200
committerzneix2021-05-11 13:49:12 +0200
commit71d04a3becc2ef37f6420ab61f8c97d0e3903767 (patch)
tree1826ce2d3e183b46cf5029a3ec07896a58508b5a
downloadaur-71d04a3becc2ef37f6420ab61f8c97d0e3903767.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore9
-rw-r--r--Makefile12
-rw-r--r--PKGBUILD31
4 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..88827642fea5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = twitch-cli-git
+ pkgdesc = The official Twitch CLI to make developing on Twitch easier, git version
+ pkgver = r224.b779fcf
+ pkgrel = 1
+ url = https://github.com/twitchdev/twitch-cli
+ arch = x86_64
+ license = Apache
+ makedepends = go
+ makedepends = git
+ provides = twitch-cli
+ conflicts = twitch-cli-bin
+ source = twitch-cli::git+https://github.com/twitchdev/twitch-cli.git
+ sha256sums = SKIP
+
+pkgname = twitch-cli-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e20683f5403e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+*.tar.xz
+*.tar.gz
+*.tar.zst
+
+pkg
+src
+
+twitch-cli-git-*
+twitch-cli
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..84e4aaecc7f8
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,12 @@
+.PHONY: all
+
+all: clean rebuild srcinfo
+
+rebuild:
+ makepkg -s
+
+srcinfo:
+ makepkg --printsrcinfo > .SRCINFO
+
+clean:
+ rm -rf pkg src twitch-cli*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d3565be638ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: zneix <zneix@zneix.eu>
+
+pkgname=twitch-cli-git
+pkgver=r224.b779fcf
+pkgrel=1
+pkgdesc='The official Twitch CLI to make developing on Twitch easier, git version'
+arch=('x86_64')
+url=https://github.com/twitchdev/twitch-cli
+license=('Apache')
+depends=()
+makedepends=('go' 'git')
+provides=('twitch-cli')
+conflicts=('twitch-cli-bin')
+source=("twitch-cli::git+https://github.com/twitchdev/twitch-cli.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/twitch-cli"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/twitch-cli"
+ go build --ldflags "-X main.buildVersion=source" -o twitch
+}
+
+package() {
+ cd "$srcdir/twitch-cli"
+ install -Dm 755 twitch "$pkgdir/usr/bin/twitch"
+ install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}