summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederik “Freso” S. Olesen2024-04-29 00:50:07 +0200
committerFrederik “Freso” S. Olesen2024-04-29 00:50:07 +0200
commit0bbdf6d1f754a536aca84b7ad45f3ac6bb0901f8 (patch)
tree279722a033f7e9f4bda8918bc7b361b7d3331195
parentc07991e9ef03e2dea28f882b09ec13684635552d (diff)
downloadaur-0bbdf6d1f754a536aca84b7ad45f3ac6bb0901f8.tar.gz
Use built module rather than system `twitch-dl`
This both prevents errors where there is no prior `twitch-dl` install, or where there’s a Python version mismatch (e.g., 3.11 vs. 3.12). Additionally, it ensures that if `make man docs` would utilise anything from a new `twitch-dl` that would actually be available from the present build instead of always only having what’s currently installed system-wide available.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f736b3fe97d..2f6731577557 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = twitch-dl
pkgdesc = Twitch video downloader that use multiple concurrent connections
pkgver = 2.3.0
- pkgrel = 6
+ pkgrel = 7
url = https://github.com/ihabunek/twitch-dl
arch = any
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index 4963284a5bad..1965ff8482c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=twitch-dl
pkgver=2.3.0
-pkgrel=6
+pkgrel=7
pkgdesc="Twitch video downloader that use multiple concurrent connections"
arch=('any')
url="https://github.com/ihabunek/twitch-dl"
@@ -37,11 +37,16 @@ build() {
cd "$pkgname-$pkgver"
export SETUPTOOLS_SCM_PRETEND_VERSION="$pkgver"
python -m build --wheel --no-isolation
+
+ # Make later commands use the built module
+ export PYTHONPATH="$PWD/build/lib"
+
make man docs
}
check() {
cd "$pkgname-$pkgver"
+ export PYTHONPATH="$PWD/build/lib"
make test
}