summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederik “Freso” S. Olesen2024-04-28 23:34:27 +0200
committerFrederik “Freso” S. Olesen2024-04-28 23:34:27 +0200
commitc07991e9ef03e2dea28f882b09ec13684635552d (patch)
tree35100c8e01a15cee9167ffd27448a6964168ab22
parent4b8d19742a0f3cc080b749d4d7eb9ebb9f0d86c2 (diff)
downloadaur-c07991e9ef03e2dea28f882b09ec13684635552d.tar.gz
Build and install documentation too
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 13 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd24770fbc2f..6f736b3fe97d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,16 @@
pkgbase = twitch-dl
pkgdesc = Twitch video downloader that use multiple concurrent connections
pkgver = 2.3.0
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/ihabunek/twitch-dl
arch = any
license = GPL3
checkdepends = python-pytest
makedepends = python-setuptools
makedepends = python-setuptools-scm
+ makedepends = mdbook
+ makedepends = python-pyaml
+ makedepends = scdoc
makedepends = python-build
makedepends = python-installer
makedepends = python-wheel
diff --git a/PKGBUILD b/PKGBUILD
index ebff43e7666e..4963284a5bad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=twitch-dl
pkgver=2.3.0
-pkgrel=5
+pkgrel=6
pkgdesc="Twitch video downloader that use multiple concurrent connections"
arch=('any')
url="https://github.com/ihabunek/twitch-dl"
@@ -16,6 +16,10 @@ depends=(
makedepends=(
python-setuptools
python-setuptools-scm
+ # Documentation building
+ mdbook
+ python-pyaml
+ scdoc
# PEP 517 build requirements
python-build
python-installer
@@ -33,6 +37,7 @@ build() {
cd "$pkgname-$pkgver"
export SETUPTOOLS_SCM_PRETEND_VERSION="$pkgver"
python -m build --wheel --no-isolation
+ make man docs
}
check() {
@@ -43,4 +48,7 @@ check() {
package() {
cd "$pkgname-$pkgver"
python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 twitch-dl.1.man "$pkgdir"/usr/share/man/man1/twitch-dl.1
+ install -Dm644 -t "$pkgdir"/usr/share/doc/"$pkgname" {CHANGELOG,TODO,README}.md
+ mv book "$pkgdir"/usr/share/doc/"$pkgname"/
}