summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraxzxc1236/佴弌2022-08-24 18:04:57 +0800
committeraxzxc1236/佴弌2022-08-24 18:04:57 +0800
commit0154e3bf8a468c5317168fa175069bc54af2773d (patch)
tree66e6d42a2d2a440689ffb874708efb617bd522eb
parent5f75c3cdc13ff9d6a2accecbc27c73f8099ec61b (diff)
downloadaur-0154e3bf8a468c5317168fa175069bc54af2773d.tar.gz
Prevent using fixed file name in PKGBUILD
-rw-r--r--.SRCINFO7
-rwxr-xr-xPKGBUILD6
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b037231a6df..767169dd8d21 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = twitch-dl-bin
pkgdesc = Twitch video downloader that use multiple concurrent connections
pkgver = 2.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ihabunek/twitch-dl
arch = any
license = GPL3
@@ -12,8 +12,7 @@ pkgbase = twitch-dl-bin
conflicts = twitch-dl
conflicts = twitch-dl-bin
noextract = twitch-dl
- source = twitch-dl::https://github.com/ihabunek/twitch-dl/releases/download/2.0.0/twitch-dl.2.0.0.pyz
- sha256sums = ('a9c632561e9b99f546b467a9b2550878d4df8b668cf0538c0f469c9d5180a84c')
+ source = https://github.com/ihabunek/twitch-dl/releases/download/2.0.0/twitch-dl.2.0.0.pyz
+ sha256sums = a9c632561e9b99f546b467a9b2550878d4df8b668cf0538c0f469c9d5180a84c
pkgname = twitch-dl-bin
-
diff --git a/PKGBUILD b/PKGBUILD
index 350b07a3a28b..7a153fa7d62a 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: axzxc1236 <axzxc1236 [(@>>] users.noreply.github.com>
pkgname=twitch-dl-bin
pkgver=2.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="Twitch video downloader that use multiple concurrent connections"
arch=(any)
url="https://github.com/ihabunek/twitch-dl"
@@ -9,11 +9,11 @@ license=('GPL3')
depends=('python' 'ffmpeg')
provides=('twitch-dl' 'twitch-dl-bin')
conflicts=('twitch-dl' 'twitch-dl-bin')
-source=('twitch-dl::https://github.com/ihabunek/twitch-dl/releases/download/2.0.0/twitch-dl.2.0.0.pyz')
+source=('https://github.com/ihabunek/twitch-dl/releases/download/2.0.0/twitch-dl.2.0.0.pyz')
sha256sums=('a9c632561e9b99f546b467a9b2550878d4df8b668cf0538c0f469c9d5180a84c')
noextract=('twitch-dl')
package() {
- install -Dm644 "${srcdir}/twitch-dl" "${pkgdir}/usr/bin/twitch-dl"
+ install -Dm644 "${srcdir}/twitch-dl.${pkgver}.pyz" "${pkgdir}/usr/bin/twitch-dl"
chmod +x ${pkgdir}/usr/bin/twitch-dl
}