summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgor Dyatlov2021-09-26 18:54:35 +0300
committerIgor Dyatlov2021-09-26 18:54:35 +0300
commit4b1aa6527aaaed96a9597d8a32f8c0bee48e2f3b (patch)
tree625489aa942a63709d0c02c91e9bfb5b42aaf058
downloadaur-4b1aa6527aaaed96a9597d8a32f8c0bee48e2f3b.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD39
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ce99e52aa2da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = twitch-dl-git
+ pkgdesc = Twitch video downloader that use multiple concurrent connections
+ pkgver = 1.16.1.r5.gdd1f4e0
+ pkgrel = 1
+ url = https://github.com/ihabunek/twitch-dl
+ arch = any
+ license = GPL3
+ checkdepends = python-pytest
+ makedepends = python-setuptools
+ depends = python
+ depends = python-m3u8
+ depends = ffmpeg
+ provides = twitch-dl
+ provides = twitch-dl-bin
+ conflicts = twitch-dl
+ conflicts = twitch-dl-bin
+ source = git+https://github.com/ihabunek/twitch-dl.git
+ sha256sums = SKIP
+
+pkgname = twitch-dl-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a4331fac867
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
+
+pkgname=twitch-dl-git
+pkgver=1.16.1.r5.gdd1f4e0
+pkgrel=1
+pkgdesc="Twitch video downloader that use multiple concurrent connections"
+arch=(any)
+url="https://github.com/ihabunek/twitch-dl"
+license=('GPL3')
+depends=('python' 'python-m3u8' 'ffmpeg')
+makedepends=('python-setuptools')
+checkdepends=('python-pytest')
+provides=('twitch-dl' 'twitch-dl-bin')
+conflicts=('twitch-dl' 'twitch-dl-bin')
+source=(git+$url.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "${pkgname%-git}"
+ make
+}
+
+check(){
+ cd "${pkgname%-git}"
+ python setup.py pytest
+}
+
+package() {
+ cd "${pkgname%-git}"
+ python setup.py install --root="$pkgdir" --optimize=1
+}