summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgor Dyatlov2023-01-15 21:42:03 +0300
committerIgor Dyatlov2023-01-15 21:42:03 +0300
commitcf90656bfaa86ca2dbc5eaac2699365db6c3f4a1 (patch)
tree6dbb918d40156a99839035cb068d3b6fb3a3e1c9
parent8ab1fb49a48f335b599e2a74f2c9a66e688b0f39 (diff)
downloadaur-cf90656bfaa86ca2dbc5eaac2699365db6c3f4a1.tar.gz
Update
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1663cf5b7f26..ce074f6a668f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = twitch-dl-git
pkgdesc = Twitch video downloader that use multiple concurrent connections
- pkgver = 1.22.0.r0.gb3a57c2
- pkgrel = 2
+ pkgver = 2.1.1.r0.g7f6e792
+ pkgrel = 1
url = https://github.com/ihabunek/twitch-dl
arch = any
license = GPL3
@@ -9,7 +9,7 @@ pkgbase = twitch-dl-git
makedepends = git
makedepends = python-setuptools
makedepends = python-wheel
- depends = python
+ depends = python-httpx
depends = python-m3u8
depends = python-requests
depends = python-pyaml
@@ -20,6 +20,6 @@ pkgbase = twitch-dl-git
conflicts = twitch-dl
conflicts = twitch-dl-bin
source = git+https://github.com/ihabunek/twitch-dl.git
- sha256sums = SKIP
+ b2sums = SKIP
pkgname = twitch-dl-git
diff --git a/PKGBUILD b/PKGBUILD
index 9a95a2841b42..0320a9e39eab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,24 @@
# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
pkgname=twitch-dl-git
-pkgver=1.22.0.r0.gb3a57c2
-pkgrel=2
+pkgver=2.1.1.r0.g7f6e792
+pkgrel=1
pkgdesc="Twitch video downloader that use multiple concurrent connections"
arch=(any)
url="https://github.com/ihabunek/twitch-dl"
license=('GPL3')
-depends=('python' 'python-m3u8' 'python-requests' 'python-pyaml' 'ffmpeg')
+depends=('python-httpx' 'python-m3u8' 'python-requests' 'python-pyaml' 'ffmpeg')
makedepends=('git' 'python-setuptools' 'python-wheel')
optdepends=('twine: Collection of utilities for interacting with PyPI')
checkdepends=('python-pytest')
provides=('twitch-dl' 'twitch-dl-bin')
conflicts=('twitch-dl' 'twitch-dl-bin')
source=(git+$url.git)
-sha256sums=('SKIP')
+b2sums=('SKIP')
pkgver() {
cd "${pkgname%-git}"
- ( set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {