summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRelwi2022-09-10 00:43:06 +0200
committerRelwi2022-09-10 00:43:06 +0200
commit1f4cd53ab823e00ed3128106a2d94d15d0626a09 (patch)
tree2d07d72f140030d7bec3406e19b3e7588257c37f
downloadaur-1f4cd53ab823e00ed3128106a2d94d15d0626a09.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..97003cdd110d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = twitch-tui
+ pkgdesc = Twitch chat in the terminal
+ pkgver = 1.6.0
+ pkgrel = 1
+ url = https://github.com/Xithrius/twitch-tui
+ arch = x86_64
+ arch = arm
+ arch = aarch64
+ license = Apache
+ makedepends = cargo
+ makedepends = git
+ source = twitch-tui-1.6.0.tar.gz::https://github.com/Xithrius/twitch-tui/archive/v1.6.0.tar.gz
+ sha256sums = 13af96c02899829fe831570e91c6ba1235648b684c71195cfb837b00202e2c39
+
+pkgname = twitch-tui
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c0ec8c81df2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Relwi <theofficialdork@hotmail.com>
+pkgname=twitch-tui
+pkgver=1.6.0
+pkgrel=1
+pkgdesc='Twitch chat in the terminal'
+url='https://github.com/Xithrius/twitch-tui'
+source=("$pkgname-$pkgver.tar.gz::https://github.com/Xithrius/twitch-tui/archive/v$pkgver.tar.gz")
+arch=(x86_64 arm aarch64)
+license=(Apache)
+makedepends=(cargo git)
+sha256sums=('13af96c02899829fe831570e91c6ba1235648b684c71195cfb837b00202e2c39')
+
+build () {
+ cd "$pkgname-$pkgver"
+ cargo build --release
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 target/release/twt "${pkgdir}/usr/bin/twt"
+}