summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRelwi2022-09-10 15:05:09 +0200
committerRelwi2022-09-10 15:05:09 +0200
commitb24315ec08c732c4030ea3215bcb9d0bcbab792b (patch)
treee48ebf3640513ba4980ac386f45e6496a54475e7
downloadaur-b24315ec08c732c4030ea3215bcb9d0bcbab792b.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b5473b160219
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = twitch-tui-alpha
+ pkgdesc = Twitch chat in the terminal
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/Xithrius/twitch-tui
+ arch = x86_64
+ arch = arm
+ arch = aarch64
+ license = Apache
+ makedepends = cargo
+ makedepends = git
+ conflicts = twitch-tui
+ source = twitch-tui-alpha-2.0.0.tar.gz::https://github.com/Xithrius/twitch-tui/archive/v2.0.0-alpha.11.tar.gz
+ sha256sums = 0cb71ec2d82448a5c1d5641247f0ec5d04ea58e364b2028cbf4cf39caa12177d
+
+pkgname = twitch-tui-alpha
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..178279557ae3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Relwi <theofficialdork@hotmail.com>
+pkgname=twitch-tui-alpha
+pkgver=2.0.0
+pkgrel=1
+pkgdesc='Twitch chat in the terminal'
+url='https://github.com/Xithrius/twitch-tui'
+source=("$pkgname-$pkgver.tar.gz::https://github.com/Xithrius/twitch-tui/archive/v$pkgver-alpha.11.tar.gz")
+arch=(x86_64 arm aarch64)
+license=(Apache)
+makedepends=(cargo git)
+conflicts=(twitch-tui)
+sha256sums=('0cb71ec2d82448a5c1d5641247f0ec5d04ea58e364b2028cbf4cf39caa12177d')
+
+build () {
+ cd "twitch-tui-$pkgver-alpha.11"
+ cargo build --release
+}
+
+package() {
+ cd "twitch-tui-$pkgver-alpha.11"
+ install -Dm755 target/release/twt "${pkgdir}/usr/bin/twt"
+}