summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBasioMeusPuga2016-12-22 21:32:31 +0530
committerBasioMeusPuga2016-12-22 21:32:31 +0530
commitbabe702ac06facff8cb075bf0749366211d50d1d (patch)
tree1e71bcd104d432faa604a0f7880ef508b3f244d4
downloadaur-babe702ac06facff8cb075bf0749366211d50d1d.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ad077584098
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = twitchy-git
+ pkgdesc = CLI livestreamer wrapper for twitch.tv
+ pkgver = r119.97431c0
+ pkgrel = 1
+ url = https://github.com/BasioMeusPuga/twitchy
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = python
+ depends = livestreamer
+ depends = python-requests
+ provides = twitchy
+ conflicts = twitchy
+ source = git://github.com/basiomeuspuga/twitchy.git
+ md5sums = SKIP
+
+pkgname = twitchy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f78733527618
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: BasioMeusPuga <disgruntled.mob@gmail.com>
+
+pkgname=twitchy-git
+_pkgname=twitchy
+pkgdesc="CLI livestreamer wrapper for twitch.tv"
+pkgver=r119.97431c0
+pkgrel=1
+arch=('i686' 'x86_64')
+url="https://github.com/BasioMeusPuga/twitchy"
+license=('GPL3')
+provides=('twitchy')
+conflicts=('twitchy')
+depends=('python' 'livestreamer' 'python-requests')
+makedepends=('git')
+source=("git://github.com/basiomeuspuga/${_pkgname}.git")
+md5sums=(SKIP)
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+package() {
+ mkdir -p ${pkgdir}/usr/share/twitchy/
+
+ install -Dm 755 twitchy/alarm.mp3 $pkgdir/usr/share/twitchy/alarm.mp3
+ install -Dm 755 twitchy/twitchy.py $pkgdir/usr/bin/twitchy
+}