summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCyrIng2015-12-17 13:37:29 +0100
committerCyrIng2015-12-17 13:37:29 +0100
commite4201c6f34be3356e53b08895cadba9506fee83b (patch)
tree7d44cafc4993791a17ffbe805a11eaba6e6ecdaf
parent15f7f6e8623db51fc39f70b037b62cb88b79b190 (diff)
downloadaur-e4201c6f34be3356e53b08895cadba9506fee83b.tar.gz
Add/Change menus keys binding.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rwxr-xr-xstart-twm-xfreq30
3 files changed, 21 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52e3aecd6d08..47727c82bb76 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = twm-xfreq
pkgdesc = A customized Twm for XFreq
- pkgver = 0.03
+ pkgver = 0.04
pkgrel = 1
url = http://github.com/cyring/xdm-xfreq
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index a51a65ffc012..c32df7b0739f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: CyrIng <xfreq[at]cyring[dot]fr>
# Contributor: CyrIng <xfreq[at]cyring[dot]fr>
pkgname=twm-xfreq
-pkgver=0.03
+pkgver=0.04
pkgrel=1
pkgdesc="A customized Twm for XFreq"
arch=(any)
diff --git a/start-twm-xfreq b/start-twm-xfreq
index 0a6ef56b8165..6c028a29a1bf 100755
--- a/start-twm-xfreq
+++ b/start-twm-xfreq
@@ -19,24 +19,28 @@ if [ -d $USERTMPFS ]; then
xrdb -load $USERTMPFS/twm-xfreq.Xresources
- echo "AutoRaise { \"TWM Icon Manager\" \"Clock\" \"PopUp\" \"XFreq-Gui\" }" > $USERTMPFS/twm-xfreq.rc
+ echo "AutoRaise { \"TWM Icon Manager\" \"Clock\" \"PopUp\" }" > $USERTMPFS/twm-xfreq.rc
echo "BorderWidth 4" >> $USERTMPFS/twm-xfreq.rc
echo "ButtonIndent 2" >> $USERTMPFS/twm-xfreq.rc
echo "DecorateTransients" >> $USERTMPFS/twm-xfreq.rc
echo "FramePadding 1" >> $USERTMPFS/twm-xfreq.rc
echo "IconBorderWidth 1" >> $USERTMPFS/twm-xfreq.rc
- echo "IconifyByUnmapping" >> $USERTMPFS/twm-xfreq.rc
+ if [[ -v WMICONLIST ]]; then
+ echo "DontIconifyByUnmapping { \"$WMICONLIST\" }" >> $USERTMPFS/twm-xfreq.rc
+ else
+ echo "IconifyByUnmapping" >> $USERTMPFS/twm-xfreq.rc
+ fi
echo "IconBorderWidth 1" >> $USERTMPFS/twm-xfreq.rc
echo "IconDirectory \"/usr/share/icons\"" >> $USERTMPFS/twm-xfreq.rc
echo "IconFont \"$WMICONFONT\"" >> $USERTMPFS/twm-xfreq.rc
- echo "IconRegion \"=160x1024+0+64\" North West 5 10" >> $USERTMPFS/twm-xfreq.rc
- echo "IconRegion \"=160x1024-0+64\" North East 5 10" >> $USERTMPFS/twm-xfreq.rc
- echo "IconManagerDontShow { \"Clock\" \"PopUp\" }" >> $USERTMPFS/twm-xfreq.rc
+ echo "IconRegion \"=160x$(( $HEIGHT - 64 ))+0+64\" North West 5 10" >> $USERTMPFS/twm-xfreq.rc
+ echo "IconRegion \"=160x$(( $HEIGHT - 64 ))-0+64\" North East 5 10" >> $USERTMPFS/twm-xfreq.rc
+ echo "IconManagerDontShow { \"Clock\" \"PopUp\" \"XFreq-Gui\" }" >> $USERTMPFS/twm-xfreq.rc
echo "IconManagerGeometry \"$(( $WIDTH - 176 ))x32+0+0\" 16" >> $USERTMPFS/twm-xfreq.rc
echo "IconManagerFont \"$WMICONFONT\"" >> $USERTMPFS/twm-xfreq.rc
echo "NoGrabServer" >> $USERTMPFS/twm-xfreq.rc
echo "NoHighlight" >> $USERTMPFS/twm-xfreq.rc
- echo "NoTitle { \"TWM Icon Manager\" \"Clock\" \"PopUp\"}" >> $USERTMPFS/twm-xfreq.rc
+ echo "NoTitle { \"TWM Icon Manager\" \"Clock\" \"PopUp\" \"XFreq-Gui\" }" >> $USERTMPFS/twm-xfreq.rc
echo "MenuBorderWidth 1" >> $USERTMPFS/twm-xfreq.rc
echo "MenuFont \"$WMMENUFONT\"" >> $USERTMPFS/twm-xfreq.rc
echo "OpaqueMove" >> $USERTMPFS/twm-xfreq.rc
@@ -93,11 +97,11 @@ if [ -d $USERTMPFS ]; then
echo " f.exec \"scrot --silent --delay 1 --exec 'xmessage -buttons Close -timeout 15 -fg \\\"$WMPOPUPFG\\\" -bg \\\"$WMPOPUPBG\\\" -bd \\\"$WMPOPUPFG\\\" -geometry -16-32 -fn $WMPOPUPFONT -name PopUp \$f &' '$USERTMPFS/%Y%m%d-%H%M%S-\$wx\$h.png'\"" >> $USERTMPFS/twm-xfreq.rc
echo "}" >> $USERTMPFS/twm-xfreq.rc
echo "" >> $USERTMPFS/twm-xfreq.rc
- echo "Button1 = : root : f.menu \"leftops\"" >> $USERTMPFS/twm-xfreq.rc
+ echo "Button3 = : root : f.menu \"leftops\"" >> $USERTMPFS/twm-xfreq.rc
echo "Button2 = : root : f.menu \"TwmWindows\"" >> $USERTMPFS/twm-xfreq.rc
- echo "Button3 = : root : f.menu \"rightops\"" >> $USERTMPFS/twm-xfreq.rc
- echo "Button4 = : root : f.warpring \"prev\"" >> $USERTMPFS/twm-xfreq.rc
- echo "Button5 = : root : f.warpring \"next\"" >> $USERTMPFS/twm-xfreq.rc
+ echo "Button1 = : root : f.menu \"rightops\"" >> $USERTMPFS/twm-xfreq.rc
+ echo "Button4 = : title|frame|iconmgr : f.circledown" >> $USERTMPFS/twm-xfreq.rc
+ echo "Button5 = : title|frame|iconmgr : f.circleup" >> $USERTMPFS/twm-xfreq.rc
echo "Button1 = : window : f.raise" >> $USERTMPFS/twm-xfreq.rc
echo "Button1 = m : window|icon : f.function \"move-or-lower\"" >> $USERTMPFS/twm-xfreq.rc
echo "Button2 = m : window|icon : f.iconify" >> $USERTMPFS/twm-xfreq.rc
@@ -115,6 +119,7 @@ if [ -d $USERTMPFS ]; then
echo "\"F2\" = : root : f.function \"run-app\"" >> $USERTMPFS/twm-xfreq.rc
echo "\"r\" = c : root : f.function \"run-app\"" >> $USERTMPFS/twm-xfreq.rc
echo "\"p\" = c : root : f.function \"screenshot-root\"" >> $USERTMPFS/twm-xfreq.rc
+ echo "\"t\" = c : root : f.exec \"exec xterm -bg '$WMTERMBG' -fg '$WMTERMFG' -name Terminal &\"" >> $USERTMPFS/twm-xfreq.rc
echo "" >> $USERTMPFS/twm-xfreq.rc
echo "menu \"winops\"" >> $USERTMPFS/twm-xfreq.rc
echo "{" >> $USERTMPFS/twm-xfreq.rc
@@ -216,7 +221,10 @@ if [ -d $USERTMPFS ]; then
echo "\"XFreq\" f.exec \"xfreq-gui -b $XFREQBACKGROUND -f $XFREQFOREGROUND &\"" >> $USERTMPFS/twm-xfreq.rc
echo "\"Clock\" f.exec \"xclock -digital -twentyfour -update 1 -strftime '$CLOCKFORMAT' -bg '$WMCLOCKBG' -fg '$WMCLOCKFG' -geometry 175x26-0+0 -fa '$WMCLOCKFACE' -name Clock &\"" >> $USERTMPFS/twm-xfreq.rc
echo "\"Terminal\" f.menu \"termops\"" >> $USERTMPFS/twm-xfreq.rc
- echo "\"Internet\" f.exec \"$(grep -w 'Exec' /usr/share/applications/$(xdg-settings get default-web-browser)|cut -d '=' -f 2) &\"" >> $USERTMPFS/twm-xfreq.rc
+ WEBBROWSER="$(grep -w 'Exec' /usr/share/applications/$(xdg-settings get default-web-browser)|cut -d '=' -f 2)"
+ if [[ $WEBBROWSER != "" ]]; then
+ echo "\"Internet\" f.exec \"$WEBBROWSER &\"" >> $USERTMPFS/twm-xfreq.rc
+ fi
echo "\"\" f.nop" >> $USERTMPFS/twm-xfreq.rc
echo "}" >> $USERTMPFS/twm-xfreq.rc