summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcyrozap2019-09-28 19:54:39 -0500
committercyrozap2019-09-28 19:54:39 -0500
commit3de80e9ceec9bf9623043214483f2a424bbbe7e7 (patch)
treee11808cbd3ba8780abd542644c089f4300505b8b
parent896b346668a4b6876041c6da4215908e651497f7 (diff)
downloadaur-3de80e9ceec9bf9623043214483f2a424bbbe7e7.tar.gz
Fix the build with newer GCC again
Replaced the patch file with a sed command to make the fix more future-proof.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--werror-fix.patch13
3 files changed, 5 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 184de5b2a2b9..c0965e82d243 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = twmn-git
pkgdesc = A notification system for tiling window managers
- pkgver = 187.80f4883
+ pkgver = 190.861a323
pkgrel = 1
url = https://github.com/sboli/twmn
arch = any
@@ -16,9 +16,7 @@ pkgbase = twmn-git
provides = notification-daemon
conflicts = twmn
source = twmn::git+https://github.com/sboli/twmn.git
- source = werror-fix.patch
sha256sums = SKIP
- sha256sums = 65aad59c679620071433864329c00486bfdd7ec3ae70cb34f7bab14f1f5fd54d
pkgname = twmn-git
diff --git a/PKGBUILD b/PKGBUILD
index bbe8c755ba19..06edf63735ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_name=twmn
pkgname="${_name}-git"
-pkgver=187.80f4883
+pkgver=190.861a323
pkgrel=1
pkgdesc="A notification system for tiling window managers"
arch=('any')
@@ -14,10 +14,8 @@ provides=('notification-daemon')
depends=('qt5-base' 'qt5-x11extras' 'boost-libs>=1.46' 'libxext' 'libxkbcommon-x11')
makedepends=('git' 'pkg-config' 'boost>=1.46')
conflicts=('twmn')
-source=("${_name}::git+https://github.com/sboli/${_name}.git"
- 'werror-fix.patch')
-sha256sums=('SKIP'
- '65aad59c679620071433864329c00486bfdd7ec3ae70cb34f7bab14f1f5fd54d')
+source=("${_name}::git+https://github.com/sboli/${_name}.git")
+sha256sums=('SKIP')
pkgver() {
cd "${_name}"
@@ -26,7 +24,7 @@ pkgver() {
prepare() {
cd "${_name}"
- patch -p1 < "${srcdir}/werror-fix.patch"
+ sed -i 's/-Werror//g' twmnd/twmnd.pro
}
build() {
diff --git a/werror-fix.patch b/werror-fix.patch
deleted file mode 100644
index 37a9134d9e39..000000000000
--- a/werror-fix.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/twmnd/twmnd.pro b/twmnd/twmnd.pro
-index 79624a5..614282f 100644
---- a/twmnd/twmnd.pro
-+++ b/twmnd/twmnd.pro
-@@ -11,7 +11,7 @@ TEMPLATE = app
- CONFIG += debug
- DESTDIR = ../bin/
- LIBS += -lX11 -lXext
--QMAKE_CXXFLAGS += -Wall -Werror -pedantic -Wno-long-long
-+QMAKE_CXXFLAGS += -Wall -pedantic -Wno-long-long
-
- target.path+=/usr/local/bin
- INSTALLS += target