summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcyrozap2019-09-10 03:44:50 -0500
committercyrozap2019-09-10 03:44:50 -0500
commit896b346668a4b6876041c6da4215908e651497f7 (patch)
treecf387bff75748d524e8ec24816f8738ce0b77790
parentdb3c096d63da143e36b7e59b617be2f30f8cd117 (diff)
downloadaur-896b346668a4b6876041c6da4215908e651497f7.tar.gz
Fix the build with newer GCC
Not bumping pkgrel because this only affects those who haven't already built the package and a rebuild isn't necessary.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
-rw-r--r--werror-fix.patch13
3 files changed, 24 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 17c2730875fa..184de5b2a2b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,7 +16,9 @@ pkgbase = twmn-git
provides = notification-daemon
conflicts = twmn
source = twmn::git+https://github.com/sboli/twmn.git
+ source = werror-fix.patch
sha256sums = SKIP
+ sha256sums = 65aad59c679620071433864329c00486bfdd7ec3ae70cb34f7bab14f1f5fd54d
pkgname = twmn-git
diff --git a/PKGBUILD b/PKGBUILD
index 33709f31763c..bbe8c755ba19 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,14 +14,21 @@ provides=('notification-daemon')
depends=('qt5-base' 'qt5-x11extras' 'boost-libs>=1.46' 'libxext' 'libxkbcommon-x11')
makedepends=('git' 'pkg-config' 'boost>=1.46')
conflicts=('twmn')
-source=("${_name}::git+https://github.com/sboli/${_name}.git")
-sha256sums=('SKIP')
+source=("${_name}::git+https://github.com/sboli/${_name}.git"
+ 'werror-fix.patch')
+sha256sums=('SKIP'
+ '65aad59c679620071433864329c00486bfdd7ec3ae70cb34f7bab14f1f5fd54d')
pkgver() {
cd "${_name}"
echo "$(git rev-list --count HEAD).$(git describe --always )"
}
+prepare() {
+ cd "${_name}"
+ patch -p1 < "${srcdir}/werror-fix.patch"
+}
+
build() {
cd "${_name}"
qmake-qt5
diff --git a/werror-fix.patch b/werror-fix.patch
new file mode 100644
index 000000000000..37a9134d9e39
--- /dev/null
+++ b/werror-fix.patch
@@ -0,0 +1,13 @@
+diff --git a/twmnd/twmnd.pro b/twmnd/twmnd.pro
+index 79624a5..614282f 100644
+--- a/twmnd/twmnd.pro
++++ b/twmnd/twmnd.pro
+@@ -11,7 +11,7 @@ TEMPLATE = app
+ CONFIG += debug
+ DESTDIR = ../bin/
+ LIBS += -lX11 -lXext
+-QMAKE_CXXFLAGS += -Wall -Werror -pedantic -Wno-long-long
++QMAKE_CXXFLAGS += -Wall -pedantic -Wno-long-long
+
+ target.path+=/usr/local/bin
+ INSTALLS += target