summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Göhler2015-06-08 12:55:44 +0200
committerMichael Göhler2015-06-08 13:02:35 +0200
commit424287f36588c479d968f9eabcc9133bbf06464e (patch)
treeff8e83a9409a50adcbe84a2148c469e1775f1dd6
downloadaur-424287f36588c479d968f9eabcc9133bbf06464e.tar.gz
initial submission to aur4
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD51
-rw-r--r--twonky.ini9
-rw-r--r--twonky.install32
-rw-r--r--twonky.service15
6 files changed, 136 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa696aab6001
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = twonky
+ pkgdesc = A DLNA-compliant UPnP AV server software from PacketVideo.
+ pkgver = 8.0.3
+ pkgrel = 1
+ url = http://twonky.com/
+ install = twonky.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = imagemagick
+ optdepends = ffmpeg: video transcoding
+ optdepends = mencoder: video transcoding
+ noextract = twonky--8.0.3.zip
+ backup = etc/twonky.ini
+ source = twonky.service
+ source = twonky.ini
+ md5sums = 4c89bcaef67cc11f02dca29aea10de1e
+ md5sums = 0c06f9de4f2510186dc50e548bb1e760
+ source_i686 = twonky-i686-8.0.3.zip::http://www.twonkyforum.com/downloads/8.0.3/twonky-i686-glibc-2.9-8.0.3.zip
+ md5sums_i686 = 67ee7af8ed177e5fabdc89ff3bc3772a
+ source_x86_64 = twonky-x86_64-8.0.3.zip::http://www.twonkyforum.com/downloads/8.0.3/twonky-x86-64-glibc-2.9-8.0.3.zip
+ md5sums_x86_64 = 8d379b58b09db68d0ff70105ccf71475
+
+pkgname = twonky
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3f9a897b4af1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.pkg.tar.xz
+twonky-*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf8da43e670b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Michael Goehler <somebody dot here at gmx dot de>
+# Contributor: picard <picard at fr32k dot de>
+
+pkgname=twonky
+pkgver=8.0.3
+pkgrel=1
+pkgdesc="A DLNA-compliant UPnP AV server software from PacketVideo."
+arch=('i686' 'x86_64')
+url="http://twonky.com/"
+license=('custom')
+depends=('imagemagick')
+optdepends=('ffmpeg: video transcoding'
+ 'mencoder: video transcoding')
+backup=('etc/twonky.ini')
+install="${pkgname}.install"
+noextract=("twonky-${CARCH}-${pkgver}.zip")
+options=('!strip')
+source=("twonky.service"
+ "twonky.ini")
+source_i686=("twonky-i686-${pkgver}.zip::http://www.twonkyforum.com/downloads/${pkgver}/twonky-i686-glibc-2.9-${pkgver}.zip")
+source_x86_64=("twonky-x86_64-${pkgver}.zip::http://www.twonkyforum.com/downloads/${pkgver}/twonky-x86-64-glibc-2.9-${pkgver}.zip")
+md5sums=('4c89bcaef67cc11f02dca29aea10de1e'
+ '0c06f9de4f2510186dc50e548bb1e760')
+md5sums_i686=('23c6e3b226a51506290d6afa4a113b0c')
+md5sums_x86_64=('7edae86bd5cfe87ef910a7639375d3a7')
+
+package() {
+ # twonky base install
+ msg2 "Extracting twonky-${CARCH}-${pkgver}.zip..."
+ install -d "${pkgdir}/usr/lib/twonky"
+ unzip -q -d "${pkgdir}/usr/lib/twonky" "${srcdir}/twonky-${CARCH}-${pkgver}.zip"
+
+ msg2 "Moving parts in place..."
+
+ # twonky config file (including defaults for appdata dir)
+ install -Dm644 "${srcdir}/twonky.ini" "${pkgdir}/etc/twonky.ini"
+
+ # twonky appdata dir (as defined in twonky.ini)
+ install -d "${pkgdir}/var/twonky/share/"{music,pictures,videos}
+
+ # systemd unit file
+ install -Dm644 "${srcdir}/twonky.service" "${pkgdir}/usr/lib/systemd/system/twonky.service"
+
+ # license files
+ cd "${pkgdir}/usr/lib/twonky"
+ for _lic in NOTICES.txt Terms*; do
+ install -Dm644 "${_lic}" "${pkgdir}/usr/share/licenses/twonky/${_lic}"
+ done
+}
+
+# vim:set ts=4 sw=4 et:
diff --git a/twonky.ini b/twonky.ini
new file mode 100644
index 000000000000..ffd43587f323
--- /dev/null
+++ b/twonky.ini
@@ -0,0 +1,9 @@
+contentbase=/var/twonky/share
+contentdir=+M|/music,+P|/pictures,+V|/videos
+followlinks=1
+ignoredir=AppleDouble,AppleDB,AppleDesktop,TemporaryItems,.fseventsd,.Spotlight-V100,.Trashes,.Trash,RECYCLED,RECYCLER,RECYCLE.BIN
+servermanagedmusicdir=/var/twonky/managed/music
+servermanagedpicturedir=/var/twonky/managed/pictures
+servermanagedvideodir=/var/twonky/managed/videos
+mediafusionserverurl=http://api.twonky.com
+profileserviceurl=http://profile.twonky.com
diff --git a/twonky.install b/twonky.install
new file mode 100644
index 000000000000..326b05ab8955
--- /dev/null
+++ b/twonky.install
@@ -0,0 +1,32 @@
+post_install() {
+ cat <<EOF
+To start Twonky:
+ # systemctl start twonky.service
+To autostart Twonky at boot time:
+ # systemctl enable twonky.service
+To add content:
+ Create symbolic links in the following directorys to
+ make only selected content available:
+ /var/twonky/share/music
+ .../pictures
+ .../videos
+ If you want to change this behavior, please edit
+ contentbase and contentdir settings in:
+ /etc/twonky.ini
+To configure Twonky via web interface:
+ http://localhost:9000/
+To configure advanced settings:
+ /etc/twonky.ini
+Documentation
+ FAQ
+ http://community.twonky.com/twonky/questions/popular
+ INI settings
+ http://www.twonkyforum.com/viewtopic.php?f=2&t=9497
+ Transcoding settings
+ /usr/lib/twonky/transcoding.html
+EOF
+}
+
+post_upgrade() {
+ post_install
+}
diff --git a/twonky.service b/twonky.service
new file mode 100644
index 000000000000..35ece6407391
--- /dev/null
+++ b/twonky.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=Twonky Server
+After=network.target
+
+[Service]
+Type=simple
+ExecStart=/usr/lib/twonky/twonkyserver \
+ -inifile /etc/twonky.ini \
+ -logfile /var/log/twonky.log \
+ -appdata /var/twonky
+Restart=always
+WorkingDirectory=/usr/lib/twonky
+
+[Install]
+WantedBy=multi-user.target