summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio Arnold2016-08-03 19:22:03 +0200
committerFabio Arnold2016-08-03 19:22:03 +0200
commita6c0b46bf15e9bb94bf55e450d8f4e6827c3ddea (patch)
treee1c978bd6ab81f80909d9fc2974091b2ea6711e8
downloadaur-a6c0b46bf15e9bb94bf55e450d8f4e6827c3ddea.tar.gz
initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD56
-rw-r--r--twotris.desktop7
-rw-r--r--twotris.install12
-rw-r--r--twotris.svg157
5 files changed, 257 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d571be1dc3e9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = twotris-git
+ pkgdesc = Edit fragment shaders and view changes in realtime
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/fabioarnold/TwoTriangles
+ install = twotris.install
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = pkg-config
+ makedepends = scons
+ depends = gtk3
+ depends = glew
+ depends = sdl2
+ provides = twotris
+ conflicts = twotris
+ source = git+https://github.com/fabioarnold/TwoTriangles.git
+ source = twotris.desktop
+ source = twotris.svg
+ sha256sums = SKIP
+ sha256sums = 0cae987cc78944940676f157e4edd002e07bf1391ca27d8ecdeea82729eb61a5
+ sha256sums = 5887528710fe01ebc498965fe6f6d76b490eafaebab4dfafca2d2d2c8ac56934
+
+pkgname = twotris-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0457d96170e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Fabio Arnold <fabio at fabioarnold dot de>
+
+_pkgname=twotris
+_version=git
+
+pkgname=${_pkgname}-${_version}
+pkgver=0.1
+pkgrel=1
+pkgdesc="Edit fragment shaders and view changes in realtime"
+arch=('x86_64' 'i686')
+url="https://github.com/fabioarnold/TwoTriangles"
+license=('MIT')
+groups=()
+depends=('gtk3' 'glew' 'sdl2')
+makedepends=('pkg-config' 'scons')
+optdepends=()
+provides=('twotris')
+conflicts=('twotris')
+replaces=()
+backup=()
+options=()
+install=${_pkgname}.install
+changelog=
+source=("git+${url}.git"
+"${_pkgname}.desktop"
+"${_pkgname}.svg")
+sha256sums=('SKIP'
+'0cae987cc78944940676f157e4edd002e07bf1391ca27d8ecdeea82729eb61a5'
+'5887528710fe01ebc498965fe6f6d76b490eafaebab4dfafca2d2d2c8ac56934')
+noextract=()
+
+prepare() {
+ cd $srcdir/TwoTriangles
+ git submodule init
+ git submodule update
+}
+
+build() {
+ cd $srcdir/TwoTriangles
+ cd lib/imgui
+ sh build_staticlib.sh
+ cd ../stb
+ sh build_staticlib.sh
+ cd ../nativefiledialog/src
+ scons debug=0
+ cd ../../..
+ sh build.sh release
+}
+
+package() {
+ cd $srcdir
+ install -Dm755 "TwoTriangles/build/${_pkgname}" "$pkgdir/usr/bin/${_pkgname}"
+ install -Dm644 "${_pkgname}.desktop" "$pkgdir/usr/share/applications/${_pkgname}.desktop"
+ install -Dm644 "${_pkgname}.svg" "$pkgdir/usr/share/icons/hicolor/scalable/apps/${_pkgname}.svg"
+ install -Dm644 "TwoTriangles/LICENSE.md" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE.md"
+}
diff --git a/twotris.desktop b/twotris.desktop
new file mode 100644
index 000000000000..a12ca248250a
--- /dev/null
+++ b/twotris.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Type=Application
+Encoding=UTF-8
+Name=TwoTriangles
+Exec=twotris
+Icon=twotris.svg
+Terminal=false
diff --git a/twotris.install b/twotris.install
new file mode 100644
index 000000000000..af0c8724a5f3
--- /dev/null
+++ b/twotris.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
diff --git a/twotris.svg b/twotris.svg
new file mode 100644
index 000000000000..63d3271fd2f4
--- /dev/null
+++ b/twotris.svg
@@ -0,0 +1,157 @@
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
+<!-- Created with Inkscape (http://www.inkscape.org/) -->
+
+<svg
+ xmlns:dc="http://purl.org/dc/elements/1.1/"
+ xmlns:cc="http://creativecommons.org/ns#"
+ xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
+ xmlns:svg="http://www.w3.org/2000/svg"
+ xmlns="http://www.w3.org/2000/svg"
+ xmlns:xlink="http://www.w3.org/1999/xlink"
+ xmlns:sodipodi="http://sodipodi.sourceforge.net/DTD/sodipodi-0.dtd"
+ xmlns:inkscape="http://www.inkscape.org/namespaces/inkscape"
+ width="48"
+ height="48"
+ viewBox="0 0 47.999998 47.999997"
+ id="svg2"
+ version="1.1"
+ inkscape:version="0.91 r13725"
+ sodipodi:docname="twotris.svg">
+ <defs
+ id="defs4">
+ <linearGradient
+ inkscape:collect="always"
+ id="linearGradient120929">
+ <stop
+ style="stop-color:#ffffff;stop-opacity:0.75208914"
+ offset="0"
+ id="stop120931" />
+ <stop
+ style="stop-color:#ffffff;stop-opacity:0.24930362"
+ offset="1"
+ id="stop120933" />
+ </linearGradient>
+ <linearGradient
+ id="green-5"
+ inkscape:collect="always">
+ <stop
+ id="stop120909"
+ offset="0"
+ style="stop-color:#78d250;stop-opacity:0" />
+ <stop
+ id="stop120911"
+ offset="1"
+ style="stop-color:#78f050;stop-opacity:1" />
+ </linearGradient>
+ <linearGradient
+ inkscape:collect="always"
+ id="blue-5">
+ <stop
+ style="stop-color:#2850f0;stop-opacity:0"
+ offset="0"
+ id="stop120870" />
+ <stop
+ style="stop-color:#2850f0;stop-opacity:1"
+ offset="1"
+ id="stop120872" />
+ </linearGradient>
+ <linearGradient
+ inkscape:collect="always"
+ xlink:href="#blue-5"
+ id="linearGradient120893"
+ x1="4"
+ y1="24"
+ x2="44"
+ y2="24"
+ gradientUnits="userSpaceOnUse" />
+ <linearGradient
+ inkscape:collect="always"
+ xlink:href="#green-5"
+ id="linearGradient120905"
+ gradientUnits="userSpaceOnUse"
+ x1="20.999998"
+ y1="31.999996"
+ x2="20.999998"
+ y2="3.9999995" />
+ <linearGradient
+ inkscape:collect="always"
+ xlink:href="#linearGradient120929"
+ id="linearGradient120935"
+ x1="23.999998"
+ y1="4.9999995"
+ x2="23.999998"
+ y2="42.999996"
+ gradientUnits="userSpaceOnUse" />
+ </defs>
+ <sodipodi:namedview
+ id="base"
+ pagecolor="#ffffff"
+ bordercolor="#666666"
+ borderopacity="1.0"
+ inkscape:pageopacity="0.0"
+ inkscape:pageshadow="2"
+ inkscape:zoom="11.313708"
+ inkscape:cx="27.396024"
+ inkscape:cy="23.294449"
+ inkscape:document-units="px"
+ inkscape:current-layer="layer1"
+ showgrid="false"
+ inkscape:showpageshadow="false"
+ units="px"
+ inkscape:window-width="1758"
+ inkscape:window-height="1243"
+ inkscape:window-x="176"
+ inkscape:window-y="548"
+ inkscape:window-maximized="0">
+ <inkscape:grid
+ type="xygrid"
+ id="grid4684" />
+ </sodipodi:namedview>
+ <metadata
+ id="metadata7">
+ <rdf:RDF>
+ <cc:Work
+ rdf:about="">
+ <dc:format>image/svg+xml</dc:format>
+ <dc:type
+ rdf:resource="http://purl.org/dc/dcmitype/StillImage" />
+ <dc:title></dc:title>
+ </cc:Work>
+ </rdf:RDF>
+ </metadata>
+ <g
+ inkscape:label="Ebene 1"
+ inkscape:groupmode="layer"
+ id="layer1"
+ transform="translate(0,-1004.3622)">
+ <path
+ style="fill:#f0463c;fill-rule:evenodd;stroke:none;stroke-width:1px;stroke-linecap:butt;stroke-linejoin:miter;stroke-opacity:1;fill-opacity:1"
+ d="M 7.5 4.5 L 43.5 40.5 L 43.5 4.5 L 7.5 4.5 z M 4.5 7.5 L 4.5 43.5 L 40.5 43.5 L 4.5 7.5 z "
+ transform="translate(0,1004.3622)"
+ id="background"
+ inkscape:label="#path4686" />
+ <path
+ inkscape:label="#path4686"
+ id="gradient1"
+ transform="translate(0,1004.3622)"
+ d="M 7.5 4.5 L 43.5 40.5 L 43.5 4.5 L 7.5 4.5 z M 4.5 7.5 L 4.5 43.5 L 40.5 43.5 L 4.5 7.5 z "
+ style="fill:url(#linearGradient120893);fill-rule:evenodd;stroke:none;stroke-width:1px;stroke-linecap:butt;stroke-linejoin:miter;stroke-opacity:1;fill-opacity:1" />
+ <path
+ style="fill:url(#linearGradient120905);fill-rule:evenodd;stroke:none;stroke-width:1px;stroke-linecap:butt;stroke-linejoin:miter;stroke-opacity:1;fill-opacity:1"
+ d="M 7.5 4.5 L 43.5 40.5 L 43.5 4.5 L 7.5 4.5 z M 4.5 7.5 L 4.5 43.5 L 40.5 43.5 L 4.5 7.5 z "
+ transform="translate(0,1004.3622)"
+ id="gradient2"
+ inkscape:label="#path4686" />
+ <path
+ style="fill:none;fill-rule:evenodd;stroke:url(#linearGradient120935);stroke-width:1px;stroke-linecap:butt;stroke-linejoin:miter;stroke-opacity:1;fill-opacity:1"
+ d="M 9.9003906 5.5 L 42.5 38.099609 L 42.5 5.5 L 9.9003906 5.5 z M 5.5 9.9003906 L 5.5 42.5 L 38.099609 42.5 L 5.5 9.9003906 z "
+ transform="translate(0,1004.3622)"
+ id="highlight" />
+ <path
+ inkscape:label="#path4686"
+ id="contours"
+ transform="translate(0,1004.3622)"
+ d="M 7.5 4.5 L 43.5 40.5 L 43.5 4.5 L 7.5 4.5 z M 4.5 7.5 L 4.5 43.5 L 40.5 43.5 L 4.5 7.5 z "
+ style="fill:none;fill-rule:evenodd;stroke:#303030;stroke-width:0.99999988;stroke-linecap:butt;stroke-linejoin:miter;stroke-opacity:1;fill-opacity:1;stroke-miterlimit:4;stroke-dasharray:none" />
+ </g>
+</svg>