summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYakumo Saki2022-06-20 21:23:46 +0900
committerYakumo Saki2022-06-20 21:23:46 +0900
commit1c70188940ee22d6f567d73d3590f54cdaadcc05 (patch)
tree8086d3139b71ef9b7dc383da25bc7bbc449b605b
parent4a9a6f8b39f6947618a72b6878d3fae727ad329f (diff)
downloadaur-1c70188940ee22d6f567d73d3590f54cdaadcc05.tar.gz
Do not check md5 of license file due to email scrambler.
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5b7919ccf43a..ce3c6f28294e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Yakumo Saki <yakumo at ziomatrix dot org>
pkgname=twty-bin
pkgver=0.0.13
-pkgrel=2
+pkgrel=3
epoch=
pkgdesc="Command-line twitter client"
arch=("x86_64")
@@ -19,12 +19,9 @@ backup=()
options=()
install=
changelog=
-source=("https://github.com/mattn/twty/releases/download/v${pkgver}/twty_v${pkgver}_linux_amd64.tar.gz"
-"LICENSE::http://mattn.mit-license.org/2017")
+source=("https://github.com/mattn/twty/releases/download/v${pkgver}/twty_v${pkgver}_linux_amd64.tar.gz")
noextract=("LICENSE")
-
-# tar.gz LICENSE
-md5sums=("c28d7e1a55950f6d1360eb362e13efed" "4d7f59aafb9ad448845b693ba105b26d")
+md5sums=("c28d7e1a55950f6d1360eb362e13efed")
validpgpkeys=()
# TO VERSION UP
# 1. Edit PKGBUILD(this file) pkgver and md5sums
@@ -40,5 +37,9 @@ package() {
mkdir -p $pkgdir/usr/bin
cp twty $pkgdir/usr/bin
chmod +x $pkgdir/usr/bin/twty
+
+ # LICENSE file is changed everytime you download it. (to hide email address)
+ # so, we dont check md5 of LICENSE
+ wget -O $srcdir/LICENSE https://mattn.mit-license.org/2017
install -D -m 644 $srcdir/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}