summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Werling2017-09-03 20:48:31 +0200
committerLukas Werling2017-09-03 20:48:31 +0200
commit3cc30249bbfd27ccf603274c871ec6f5c4a55d43 (patch)
tree4d7be3550f0235a712eb254334683eb2242997b0
downloadaur-3cc30249bbfd27ccf603274c871ec6f5c4a55d43.tar.gz
txr-185
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..329a329f9e6b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sun Sep 3 18:48:21 UTC 2017
+pkgbase = txr
+ pkgdesc = A data munging language.
+ pkgver = 185
+ pkgrel = 1
+ url = http://nongnu.org/txr/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = libffi
+ source = http://www.kylheku.com/cgit/txr/snapshot/txr-185.tar.bz2
+ sha256sums = a075372a1ac6e62cf30482aa5f483ac4a40534d4a855a4c08ed59c3b7589ce26
+
+pkgname = txr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc6887a6e8cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Lukas Werling <lukas.werling@gmail.com>
+pkgname=txr
+pkgver=185
+pkgrel=1
+pkgdesc="A data munging language."
+arch=('i686' 'x86_64')
+url="http://nongnu.org/txr/"
+license=('BSD')
+depends=('libffi')
+makedepends=()
+source=("http://www.kylheku.com/cgit/txr/snapshot/txr-${pkgver}.tar.bz2")
+sha256sums=('a075372a1ac6e62cf30482aa5f483ac4a40534d4a855a4c08ed59c3b7589ce26')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ # Tests have to run sequentially.
+ make -j1 tests.clean tests
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ # txr installs licenses to /usr/share/txr. Add symlinks from Arch's
+ # usual license directory.
+ mkdir -p "$pkgdir/usr/share/licenses/txr"
+ ln -s -t "$pkgdir/usr/share/licenses/txr" ../../txr/LICENSE ../../txr/METALICENSE
+}