summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrett2021-11-20 23:05:45 +0000
committerBrett2021-11-20 23:05:45 +0000
commita28a6bebb2cc1a495c5349095098f4a1b204bb2b (patch)
tree9423e83e3b6171bf1cbba3a7fe42d117fb3ac996
downloadaur-a28a6bebb2cc1a495c5349095098f4a1b204bb2b.tar.gz
Intial package creation
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD23
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ac16a1a572d2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = txt
+ pkgdesc = A shitty text editor written in C99
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/ItzAfroBoy/txt.git
+ arch = any
+ license = GPL3
+ source = git+https://github.com/ItzAfroBoy/txt.git
+ md5sums = SKIP
+
+pkgname = txt
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ebe337229fb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Brett Lee (ItzAfroBoy) <me.caramackid@gmail.com>
+pkgname=txt
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A shitty text editor written in C99"
+arch=('any')
+url="https://github.com/ItzAfroBoy/txt.git"
+license=('GPL3')
+source=("git+$url")
+md5sums=('SKIP')
+
+build() {
+ cd "${pkgname}"
+ make
+}
+
+package() {
+ cd "${pkgname}"
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm 644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+ mkdir -p "${pkgdir}/usr/bin"
+ make BIN="${pkgdir}/usr/bin" install
+}