summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Max Meyer2017-08-01 18:00:28 +0200
committerJan Max Meyer2017-08-01 18:00:28 +0200
commit1d1e91aa33a6f543d88e53dc4ff66e508736e864 (patch)
tree6f906771161f10cea9401d6e79c9590e51c4d834
downloadaur-1d1e91aa33a6f543d88e53dc4ff66e508736e864.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0c230c49c158
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = txt2tags-git
+ pkgdesc = A text formatting and conversion tool - Development version
+ pkgver = 2.6.99
+ pkgrel = 1
+ url = http://www.txt2tags.org
+ arch = any
+ license = GPL
+ makedepends = gettext,
+ makedepends = git
+ depends = python2
+ optdepends = ruby: for running t2tmake.rb
+ optdepends = sh: for running html-update.sh
+ optdepends = vim: for using the vim-files
+ conflicts = txt2tags
+ source = git://github.com/txt2tags/txt2tags.git
+ md5sums = SKIP
+
+pkgname = txt2tags-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e714a20f30b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Jan Max Meyer <codepilot@phorward.info>
+_txt2tags=txt2tags
+pkgname=$_txt2tags-git
+pkgver=2.6.99
+pkgrel=1
+epoch=
+pkgdesc="A text formatting and conversion tool - Development version"
+arch=('any')
+url="http://www.txt2tags.org"
+license=('GPL')
+conflicts=("$_txt2tags")
+depends=('python2')
+optdepends=('ruby: for running t2tmake.rb'
+ 'sh: for running html-update.sh'
+ 'vim: for using the vim-files')
+makedepends=('gettext', 'git')
+source=("git://github.com/txt2tags/txt2tags.git")
+md5sums=('SKIP')
+
+build() {
+ cd "$pkgname-$pkgver"
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ python2 setup.py check
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir/"
+}
+