summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Max Meyer2017-08-01 18:11:52 +0200
committerJan Max Meyer2017-08-01 18:11:52 +0200
commit36debf2c7fb5b4feca2b582cdafbe1a8b3f7a0a5 (patch)
tree87c86cd79026a5931ff6677f53a320957627e171
parent1d1e91aa33a6f543d88e53dc4ff66e508736e864 (diff)
downloadaur-36debf2c7fb5b4feca2b582cdafbe1a8b3f7a0a5.tar.gz
First working package.
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD16
2 files changed, 6 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c230c49c158..cccf113950fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,6 @@ pkgbase = txt2tags-git
url = http://www.txt2tags.org
arch = any
license = GPL
- makedepends = gettext,
makedepends = git
depends = python2
optdepends = ruby: for running t2tmake.rb
diff --git a/PKGBUILD b/PKGBUILD
index e714a20f30b5..c6f3957e7b47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Jan Max Meyer <codepilot@phorward.info>
-_txt2tags=txt2tags
-pkgname=$_txt2tags-git
+_pkgname=txt2tags
+pkgname=$_pkgname-git
pkgver=2.6.99
pkgrel=1
epoch=
@@ -8,26 +8,22 @@ pkgdesc="A text formatting and conversion tool - Development version"
arch=('any')
url="http://www.txt2tags.org"
license=('GPL')
-conflicts=("$_txt2tags")
+conflicts=("$_pkgname")
depends=('python2')
optdepends=('ruby: for running t2tmake.rb'
'sh: for running html-update.sh'
'vim: for using the vim-files')
-makedepends=('gettext', 'git')
+makedepends=('git')
source=("git://github.com/txt2tags/txt2tags.git")
md5sums=('SKIP')
-build() {
- cd "$pkgname-$pkgver"
-}
-
check() {
- cd "$pkgname-$pkgver"
+ cd "$srcdir/$_pkgname"
python2 setup.py check
}
package() {
- cd "$pkgname-$pkgver"
+ cd "$srcdir/$_pkgname"
python2 setup.py install --root="$pkgdir/"
}