summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNiels Martignène2017-05-28 12:54:58 +0200
committerNiels Martignène2017-05-28 12:54:58 +0200
commitb8262524917e8e8d5dda3d37437cdd5f837aa5d3 (patch)
treeee3498ea9cf9136d00649f5e71ed9658e0adaa1f
parent9409ab436dd304d7050d9b3cc88b9069aec247dc (diff)
downloadaur-b8262524917e8e8d5dda3d37437cdd5f837aa5d3.tar.gz
Upragde to TyTools 0.8.5
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
2 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8cfb12cf30dd..c9369ac6ba5a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = ty
- pkgdesc = GUI and command-line tools to manage Teensy devices
- pkgver = 0.8.0
+ pkgdesc = Collection of tools to manage Teensy boards
+ pkgver = 0.8.5
pkgrel = 1
- url = http://github.com/Koromix/ty
+ url = http://github.com/Koromix/tytools
arch = x86_64
arch = i686
- license = MIT
+ license = custom:Unlicense
makedepends = imagemagick
depends = teensyduino
depends = libudev.so
depends = qt5-base
- source = https://github.com/Koromix/ty/archive/v0.8.0.tar.gz
+ source = https://github.com/Koromix/ty/archive/v0.8.5.tar.gz
sha256sums = 68d3e671f898fa78ff8a57caacc2fabbe52fc84864fe03c5c60de9b1feee542a
pkgname = ty
diff --git a/PKGBUILD b/PKGBUILD
index 8ad8be6951ce..28a858626d07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,35 @@
# Maintainer: Niels Martignène <niels.martignene@gmail.com>
pkgname=ty
-pkgver=0.8.0
+pkgver=0.8.5
pkgrel=1
-pkgdesc="GUI and command-line tools to manage Teensy devices"
+pkgdesc="Collection of tools to manage Teensy boards"
arch=('x86_64' 'i686')
-url="http://github.com/Koromix/ty"
-license=('MIT')
+url="http://github.com/Koromix/tytools"
+license=('custom:Unlicense')
depends=('teensyduino' 'libudev.so' 'qt5-base')
makedepends=('imagemagick')
source=("https://github.com/Koromix/ty/archive/v${pkgver}.tar.gz")
-sha256sums=('68d3e671f898fa78ff8a57caacc2fabbe52fc84864fe03c5c60de9b1feee542a')
+sha256sums=('a4ae6b3f39e491c21fe58b6bd84c158cbb7cad3bade2c7159dffbf1d2f026583')
build() {
- cd "ty-${pkgver}"
+ cd "tytools-${pkgver}"
cmake -DCMAKE_INSTALL_PREFIX=/usr
make
}
package() {
- cd "ty-${pkgver}"
+ cd "tytools-${pkgver}"
make install DESTDIR="${pkgdir}"
for size in 16 32 48 256; do
mkdir -p "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps"
- convert -resize "${size}x${size}" src/tyqt/images/tyqt.png "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps/tyqt.png"
- convert -resize "${size}x${size}" src/upty/images/upty.png "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps/upty.png"
+ convert -resize "${size}x${size}" resources/images/tycommander.png \
+ "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps/tycommander.png"
+ convert -resize "${size}x${size}" resources/images/tyupdater.png \
+ "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps/tyupdater.png"
done
install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/ty/LICENSE.txt"