summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorendaaman2017-04-03 23:12:11 +0900
committerendaaman2017-04-03 23:12:11 +0900
commite80ceebfe4b65dae9f8cb486f9f7db89f4abf66a (patch)
treeca27a0e8bd7a625f2db6c0300f739bcdbd81ad82
downloadaur-e80ceebfe4b65dae9f8cb486f9f7db89f4abf66a.tar.gz
version 0.1.0
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD23
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4dc520eb9135
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Mon Apr 3 13:40:21 UTC 2017
+pkgbase = tym
+ pkgdesc = A tiny term for minimalists
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/endaaman/tym
+ arch = x86_64
+ license = MIT
+ depends = vte3
+ depends = lua
+ source = https://github.com/endaaman/tym/releases/download/0.1.0/tym-0.1.0.tar.gz
+ sha1sums = 1c625f66b16d7e3743ee592f423593439c40eede
+
+pkgname = tym
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..47af16ed06d2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+src
+pkg
+*.tar.xz
+*.tar.gz
+*.log
+.psci_modules
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..74e89de3e5e7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Ken Enda <buhibuhidog@gmail.com>
+
+pkgname=tym
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="A tiny term for minimalists"
+arch=('x86_64')
+url="https://github.com/endaaman/tym"
+license=('MIT')
+depends=( 'vte3' 'lua' )
+source=("https://github.com/endaaman/${pkgname}/releases/download/$pkgver/${pkgname}-$pkgver.tar.gz")
+sha1sums=('1c625f66b16d7e3743ee592f423593439c40eede')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}