summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororhun2020-10-20 19:17:16 +0300
committerorhun2020-10-20 19:17:16 +0300
commit7b21293a4bb0e316a518c6dd2209a5f3fb426aef (patch)
treeeba200e37609c281388112a3deba8429af9ca55e
downloadaur-7b21293a4bb0e316a518c6dd2209a5f3fb426aef.tar.gz
Initial upload: typeracer-git 2.0.3.r0.g0249e62-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD38
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..72a537ad0ebe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = typeracer-git
+ pkgdesc = terminal typing speed tester (git)
+ pkgver = 2.0.3.r0.g0249e62
+ pkgrel = 1
+ url = https://gitlab.com/ttyperacer/terminal-typeracer
+ arch = x86_64
+ license = GPL3
+ makedepends = cargo
+ makedepends = git
+ depends = openssl
+ depends = zlib
+ provides = typeracer
+ conflicts = typeracer
+ source = git+https://gitlab.com/ttyperacer/terminal-typeracer
+ sha512sums = SKIP
+
+pkgname = typeracer-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c29961f1611
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: orhun <orhunparmaksiz@gmail.com>
+# https://github.com/orhun/pkgbuilds
+
+_pkgname=terminal-typeracer
+pkgname=typeracer-git
+pkgver=2.0.3.r0.g0249e62
+pkgrel=1
+pkgdesc="terminal typing speed tester (git)"
+arch=('x86_64')
+url="https://gitlab.com/ttyperacer/terminal-typeracer"
+license=('GPL3')
+depends=('openssl' 'zlib')
+makedepends=('cargo' 'git')
+conflicts=("${pkgname%-git}")
+provides=("${pkgname%-git}")
+source=("git+${url}")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$_pkgname"
+ cargo build --release --locked --all-features
+}
+
+check() {
+ cd "$_pkgname"
+ cargo test --release --locked
+}
+
+package() {
+ cd "$_pkgname"
+ install -Dm 755 "target/release/${pkgname%-git}" -t "$pkgdir/usr/bin"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/${pkgname%-git}"
+}