summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpikl2023-08-26 13:19:51 +0100
committerpikl2023-08-26 13:19:51 +0100
commit7ae60f34e38299d82217402ffa028375256cbf7d (patch)
tree70e4fcf9bf79e8bd7043de3c2c09e45611fb5b1c
parent2351656eb24185440ab96414f96c518caeaf6f37 (diff)
downloadaur-7ae60f34e38299d82217402ffa028375256cbf7d.tar.gz
initial test
-rw-r--r--PKGBUILD60
1 files changed, 28 insertions, 32 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 05866ecb90c9..71c0abbb4463 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,53 +1,49 @@
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
-
-# Maintainer: Your Name <youremail@domain.com>
-pkgname=NAME
+# Maintainer: pikl <me@pikl.uk>
+_pkgroot=typesense
+pkgname="${_pkgroot}-bin"
pkgver=VERSION
-pkgrel=1
+pkgrel=0.25.0
epoch=
-pkgdesc=""
+pkgdesc="A fast, typo-tolerant search engine for building delightful search experiences."
arch=()
-url=""
-license=('GPL')
+url="https://github.com/typesense/typesense"
+license=('GPL3')
groups=()
depends=()
makedepends=()
checkdepends=()
optdepends=()
-provides=()
+provides=("${_pkgroot}")
conflicts=()
replaces=()
backup=()
options=()
install=
changelog=
-source=("$pkgname-$pkgver.tar.gz"
- "$pkgname-$pkgver.patch")
+source=("https://dl.typesense.org/releases/${pkgrel}/${_pkgroot}-server-${pkgrel}-linux.amd64.tar.gz")
noextract=()
-md5sums=()
+sha256sums=()
validpgpkeys=()
-prepare() {
- cd "$pkgname-$pkgver"
- patch -p1 -i "$srcdir/$pkgname-$pkgver.patch"
-}
-
-build() {
- cd "$pkgname-$pkgver"
- ./configure --prefix=/usr
- make
-}
-
-check() {
- cd "$pkgname-$pkgver"
- make -k check
-}
+# prepare() {
+# cd "$pkgname-$pkgver"
+# patch -p1 -i "$srcdir/$pkgname-$pkgver.patch"
+# }
+#
+# build() {
+# cd "$pkgname-$pkgver"
+# ./configure --prefix=/usr
+# make
+# }
+#
+# check() {
+# cd "$pkgname-$pkgver"
+# make -k check
+# }
package() {
- cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
+ :
+ # cd "$pkgname-$pkgver"
+ # make DESTDIR="$pkgdir/" install
}