summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZijia Xiong2023-03-18 19:00:50 +0000
committerZijia Xiong2023-03-18 19:00:50 +0000
commit6c7200006d51deccddaf42cac1b33598eae19066 (patch)
treea79b6d0f79ae8e5beb23e9757f413415d64044c6
downloadaur-6c7200006d51deccddaf42cac1b33598eae19066.tar.gz
First commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
-rw-r--r--typing-tempo.desktop9
4 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..74d6b62cd081
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = typing-tempo
+ pkgdesc = Typing Tempo is a 41-key 2D typing rhythm game currently in development, available for Windows and Linux.
+ pkgver = 0.4.4
+ pkgrel = 1
+ url = https://rainbeatgames.itch.io/typing-tempo
+ arch = i686
+ arch = x86_64
+ source = file:///$HOME/Downloads/typing-tempo-$pkgver-linux.zip
+ source = typing-tempo.desktop
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = typing-tempo
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b38a53a89259
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.tar.*
+*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a70f34423b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: RRRRRm <isxiongzj@gmail.com>
+pkgname=typing-tempo
+pkgver=0.4.4
+pkgrel=1
+pkgdesc="Typing Tempo is a 41-key 2D typing rhythm game currently in development, available for Windows and Linux."
+arch=('i686' 'x86_64')
+url="https://rainbeatgames.itch.io/typing-tempo"
+source=("file://$HOME/Downloads/typing-tempo-${pkgver}-linux.zip"
+"typing-tempo.desktop")
+md5sums=('SKIP' 'SKIP')
+
+package() {
+ install -dm755 "$pkgdir/opt/typing-tempo"
+
+ cp -r "$srcdir/typing-tempo-${pkgver}-linux/"* "$pkgdir/opt/typing-tempo"
+
+ cd "$pkgdir/opt/typing-tempo"
+
+ chmod +x "./typing-tempo.sh"
+ sed -i '1a cd /opt/typing-tempo' "./typing-tempo.sh"
+ ln -s "libSDL3.so.0.0.0" "libSDL3.so.0"
+ ln -s "libSDL3_ttf.so.0.0.0" "libSDL3_ttf.so.0"
+ ln -s "libSDL3_image.so.0.0.0" "libSDL3_image.so.0"
+
+ mkdir -p "$pkgdir/usr/bin"
+ ln -s "/opt/typing-tempo/typing-tempo.sh" "$pkgdir"/usr/bin/typing-tempo
+
+ install -Dm644 "$srcdir/typing-tempo.desktop" "$pkgdir/usr/share/applications/typing-tempo.desktop"
+}
diff --git a/typing-tempo.desktop b/typing-tempo.desktop
new file mode 100644
index 000000000000..a947a43914c1
--- /dev/null
+++ b/typing-tempo.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Typing Tempo
+Comment=Typing Tempo is a 41-key 2D typing rhythm game currently in development, available for Windows and Linux.
+Exec=/usr/bin/typing-tempo
+Icon=/opt/typing-tempo/res/images/windowIcon.ico
+Categories=Game;
+Terminal=false