summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Pérez2022-05-13 14:29:21 -0600
committerLuis Pérez2022-05-13 14:29:21 -0600
commit5a68c09cab91ebddb8b4979289ff800e932306ba (patch)
tree0345b598181e39fd051fb6e2b3f37e39acd3cadb
downloadaur-5a68c09cab91ebddb8b4979289ff800e932306ba.tar.gz
first package version
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..95f2d97b0885
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = typioca
+ pkgdesc = Tapioca (/ˌtæpiˈoʊkə/) is a starch extracted from the storage roots of the cassava plant. Pearl tapioca is a common ingredient in Asian desserts...and sweet drinks such as bubble tea.
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/bloznelis/typioca
+ arch = any
+ license = MIT
+ makedepends = go
+ makedepends = make
+ provides = typioca
+ source = https://github.com/bloznelis/typioca/archive/refs/tags/1.0.1.tar.gz
+ sha256sums = fa28239cd5fdb11ea0c2aba32cff767a7ce46f18d769f821797c6942ae2b9052
+
+pkgname = typioca
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..42f8f31c48cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Luis Pérez <luis dot perez at protonmail dot com>
+pkgname=typioca
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="Tapioca (/ˌtæpiˈoʊkə/) is a starch extracted from the storage roots of the cassava plant. Pearl tapioca is a common ingredient in Asian desserts...and sweet drinks such as bubble tea."
+arch=(any)
+url="https://github.com/bloznelis/typioca"
+license=('MIT')
+makedepends=('go' 'make')
+provides=(typioca)
+conflicts=()
+source=("https://github.com/bloznelis/typioca/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('fa28239cd5fdb11ea0c2aba32cff767a7ce46f18d769f821797c6942ae2b9052')
+
+build() {
+ cd "$pkgname-$pkgver"
+ make build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 "${srcdir}/$pkgname-$pkgver/execs/typioca" "${pkgdir}/usr/bin/typioca"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}