summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgor Dyatlov2021-08-12 15:50:44 +0300
committerIgor Dyatlov2021-08-12 15:50:44 +0300
commit13bf5bad1e5bf5e47e88cb02935152b6f73cea0c (patch)
treee2ef161265482d070914d81dcc6db302f5605d30
parent25e578556c6e0263115c77ba0cc6805c42039566 (diff)
downloadaur-13bf5bad1e5bf5e47e88cb02935152b6f73cea0c.tar.gz
Updates
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a0294993b538..31653942e1e1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,10 +5,10 @@ pkgbase = typography
url = https://gitlab.gnome.org/World/design/typography
arch = any
license = GPL3
- makedepends = git
+ checkdepends = appstream-glib
makedepends = meson
depends = gtk4
- source = git+https://gitlab.gnome.org/World/design/typography.git#tag=0.1.0
- md5sums = SKIP
+ source = https://gitlab.gnome.org/World/design/typography/-/archive/0.1.0/typography-0.1.0.tar.gz
+ sha256sums = 7990df024495c6018f066273b91ab8f6bf27e4ea2dc2f506bc18420b4ed769b0
pkgname = typography
diff --git a/PKGBUILD b/PKGBUILD
index 791734edd20f..70106f1e43b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,12 +8,13 @@ arch=('any')
url="https://gitlab.gnome.org/World/design/typography"
license=('GPL3')
depends=('gtk4')
-makedepends=('git' 'meson')
-source=("git+${url}.git#tag=${pkgver}")
-md5sums=('SKIP') #autofill using updpkgsums
+makedepends=('meson')
+checkdepends=('appstream-glib')
+source=($url/-/archive/$pkgver/$pkgname-$pkgver.tar.gz)
+sha256sums=('7990df024495c6018f066273b91ab8f6bf27e4ea2dc2f506bc18420b4ed769b0')
build() {
- arch-meson $pkgname build
+ arch-meson $pkgname-$pkgver build
meson compile -C build
}