summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgor Dyatlov2021-08-03 16:12:06 +0300
committerIgor Dyatlov2021-08-03 16:12:06 +0300
commit25e578556c6e0263115c77ba0cc6805c42039566 (patch)
tree1b6d76d6ea6d26629efb0536018ccddd95bf36b6
downloadaur-25e578556c6e0263115c77ba0cc6805c42039566.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a0294993b538
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = typography
+ pkgdesc = Tool for working with the GNOME typography design guidelines
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://gitlab.gnome.org/World/design/typography
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = meson
+ depends = gtk4
+ source = git+https://gitlab.gnome.org/World/design/typography.git#tag=0.1.0
+ md5sums = SKIP
+
+pkgname = typography
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..791734edd20f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
+
+pkgname=typography
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Tool for working with the GNOME typography design guidelines"
+arch=('any')
+url="https://gitlab.gnome.org/World/design/typography"
+license=('GPL3')
+depends=('gtk4')
+makedepends=('git' 'meson')
+source=("git+${url}.git#tag=${pkgver}")
+md5sums=('SKIP') #autofill using updpkgsums
+
+build() {
+ arch-meson $pkgname build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ DESTDIR="${pkgdir}" meson install -C build
+} \ No newline at end of file