summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJake Leahy2023-04-08 17:21:02 +1000
committerJake Leahy2023-04-08 17:21:28 +1000
commit1af03ab3408b574184a6ad30e5dd90a6550b8544 (patch)
treeabaa4d3cdcfeda37b4c6ed154f2c250e171fdf14
parent3f98eb2fc26486de367cf1f590cee5640271eb99 (diff)
downloadaur-1af03ab3408b574184a6ad30e5dd90a6550b8544.tar.gz
Update sources so that the hashes are generated correctly
This uses the suggestion from AsukaMinato
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6dc704637e34..8c1bc6b19f15 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = typst-lsp-bin
pkgdesc = A brand-new language server for Typst,
pkgver = 0.3.2
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/nvarner/typst-lsp
arch = x86_64
arch = armv7h
@@ -10,11 +10,11 @@ pkgbase = typst-lsp-bin
depends = glibc
depends = gcc-libs
provides = typst-lsp
- source_x86_64 = typst-lsp-0.3.2::https://github.com/nvarner/typst-lsp/releases/download/v0.3.2/typst-lsp-linux-x64
+ source_x86_64 = typst-lsp_x86_64-0.3.2::https://github.com/nvarner/typst-lsp/releases/download/v0.3.2/typst-lsp-linux-x64
sha256sums_x86_64 = 0b3f629ea1350fb03c864661949d338b5d720b5aefbc72f0241fa3c60b020dad
- source_armv7h = typst-lsp-0.3.2::https://github.com/nvarner/typst-lsp/releases/download/v0.3.2/typst-lsp-linux-armhf
- sha256sums_armv7h = 0b3f629ea1350fb03c864661949d338b5d720b5aefbc72f0241fa3c60b020dad
- source_aarch64 = typst-lsp-0.3.2::https://github.com/nvarner/typst-lsp/releases/download/v0.3.2/typst-lsp-linux-arm64
- sha256sums_aarch64 = 0b3f629ea1350fb03c864661949d338b5d720b5aefbc72f0241fa3c60b020dad
+ source_armv7h = typst-lsp_armv7-0.3.2::https://github.com/nvarner/typst-lsp/releases/download/v0.3.2/typst-lsp-linux-armhf
+ sha256sums_armv7h = c72ec0e4298ccb0109f26f48af810996d069a5dedfdab56591c38821b8beded8
+ source_aarch64 = typst-lsp_aarch64-0.3.2::https://github.com/nvarner/typst-lsp/releases/download/v0.3.2/typst-lsp-linux-arm64
+ sha256sums_aarch64 = ee6036ea7af1538a3b2cfc9eb50ba81cd6c31e8745d455a5828ed575cbb8b66c
pkgname = typst-lsp-bin
diff --git a/PKGBUILD b/PKGBUILD
index f7f674c302c3..51defa0d6e13 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,19 @@
pkgname=typst-lsp-bin
pkgver=0.3.2
-pkgrel=2
+pkgrel=3
pkgdesc="A brand-new language server for Typst,"
arch=("x86_64" "armv7h" "aarch64")
url="https://github.com/nvarner/typst-lsp"
license=("MIT")
-source_x86_64=("typst-lsp-$pkgver::https://github.com/nvarner/typst-lsp/releases/download/v$pkgver/typst-lsp-linux-x64")
-source_armv7h=("typst-lsp-$pkgver::https://github.com/nvarner/typst-lsp/releases/download/v$pkgver/typst-lsp-linux-armhf")
-source_aarch64=("typst-lsp-$pkgver::https://github.com/nvarner/typst-lsp/releases/download/v$pkgver/typst-lsp-linux-arm64")
+source_x86_64=("typst-lsp_x86_64-$pkgver::https://github.com/nvarner/typst-lsp/releases/download/v$pkgver/typst-lsp-linux-x64")
+source_armv7h=("typst-lsp_armv7-$pkgver::https://github.com/nvarner/typst-lsp/releases/download/v$pkgver/typst-lsp-linux-armhf")
+source_aarch64=("typst-lsp_aarch64-$pkgver::https://github.com/nvarner/typst-lsp/releases/download/v$pkgver/typst-lsp-linux-arm64")
sha256sums_x86_64=('0b3f629ea1350fb03c864661949d338b5d720b5aefbc72f0241fa3c60b020dad')
-sha256sums_armv7h=('0b3f629ea1350fb03c864661949d338b5d720b5aefbc72f0241fa3c60b020dad')
-sha256sums_aarch64=('0b3f629ea1350fb03c864661949d338b5d720b5aefbc72f0241fa3c60b020dad')
+sha256sums_armv7h=('c72ec0e4298ccb0109f26f48af810996d069a5dedfdab56591c38821b8beded8')
+sha256sums_aarch64=('ee6036ea7af1538a3b2cfc9eb50ba81cd6c31e8745d455a5828ed575cbb8b66c')
provides=("typst-lsp")
depends=("glibc" "gcc-libs")