summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJake Leahy2023-04-01 15:54:03 +1100
committerJake Leahy2023-04-01 15:54:03 +1100
commite0963430c7a76f891d348880acb83fa0fbf8755b (patch)
tree7db6a1883cc46dd56300b0168ca5d583a0e943ad
downloadaur-e0963430c7a76f891d348880acb83fa0fbf8755b.tar.gz
Add typst lsp files
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD25
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e5dee852edda
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = typst-lsp-bin
+ pkgdesc = A brand-new language server for Typst,
+ pkgver = 0.3.1
+ pkgrel = 1
+ url = https://github.com/nvarner/typst-lsp
+ arch = x86_64
+ arch = armv7h
+ arch = aarch64
+ license = GPL3
+ depends = qt5-base
+ provides = typst-lsp
+ source_x86_64 = typst-lsp-0.3.1::https://github.com/nvarner/typst-lsp/releases/download/v0.3.1/typst-lsp-linux-x64
+ sha256sums_x86_64 = 8927a35f00e34908c1b015a5f6da626e187a56fdb4bd4232ff2809076f420389
+ source_armv7h = typst-lsp-0.3.1::https://github.com/nvarner/typst-lsp/releases/download/v0.3.1/typst-lsp-linux-armhf
+ sha256sums_armv7h = 8927a35f00e34908c1b015a5f6da626e187a56fdb4bd4232ff2809076f420389
+ source_aarch64 = typst-lsp-0.3.1::https://github.com/nvarner/typst-lsp/releases/download/v0.3.1/typst-lsp-linux-arm64
+ sha256sums_aarch64 = 8927a35f00e34908c1b015a5f6da626e187a56fdb4bd4232ff2809076f420389
+
+pkgname = typst-lsp-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..00009d24dfef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Jake Leahy <jake@lowerCaseLastName.dev
+
+pkgname=typst-lsp-bin
+pkgver=0.3.1
+pkgrel=1
+pkgdesc="A brand-new language server for Typst,"
+arch=("x86_64" "armv7h" "aarch64")
+url="https://github.com/nvarner/typst-lsp"
+license=("GPL3")
+
+source_x86_64=("typst-lsp-$pkgver::https://github.com/nvarner/typst-lsp/releases/download/v$pkgver/typst-lsp-linux-x64")
+source_armv7h=("typst-lsp-$pkgver::https://github.com/nvarner/typst-lsp/releases/download/v$pkgver/typst-lsp-linux-armhf")
+source_aarch64=("typst-lsp-$pkgver::https://github.com/nvarner/typst-lsp/releases/download/v$pkgver/typst-lsp-linux-arm64")
+
+sha256sums_x86_64=('8927a35f00e34908c1b015a5f6da626e187a56fdb4bd4232ff2809076f420389')
+sha256sums_armv7h=('8927a35f00e34908c1b015a5f6da626e187a56fdb4bd4232ff2809076f420389')
+sha256sums_aarch64=('8927a35f00e34908c1b015a5f6da626e187a56fdb4bd4232ff2809076f420389')
+
+provides=("typst-lsp")
+depends=("qt5-base")
+
+package() {
+ cd "$srcdir/"
+ install -Dm 755 typst-lsp-$pkgver "${pkgdir}/usr/bin/typst-lsp"
+}