summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJake Leahy2023-04-08 17:35:30 +1000
committerJake Leahy2023-04-08 17:35:30 +1000
commitf06b7deeeb26e5efa1c385b8b667fc74670a8770 (patch)
tree269e22c0fa4d4e7fad724cd001fb93a5d8a4946a
parent6e09f3e2a7b03074d430bf5ea3093e7d885a2c9a (diff)
downloadaur-f06b7de.tar.gz
Fix package() step not finding binaries
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c1bc6b19f15..39ccb8dd0ca2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = typst-lsp-bin
- pkgdesc = A brand-new language server for Typst,
+ pkgdesc = A brand-new language server for Typst
pkgver = 0.3.2
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/nvarner/typst-lsp
arch = x86_64
arch = armv7h
@@ -10,11 +10,11 @@ pkgbase = typst-lsp-bin
depends = glibc
depends = gcc-libs
provides = typst-lsp
- source_x86_64 = typst-lsp_x86_64-0.3.2::https://github.com/nvarner/typst-lsp/releases/download/v0.3.2/typst-lsp-linux-x64
+ source_x86_64 = typst-lsp-x86_64-0.3.2::https://github.com/nvarner/typst-lsp/releases/download/v0.3.2/typst-lsp-linux-x64
sha256sums_x86_64 = 0b3f629ea1350fb03c864661949d338b5d720b5aefbc72f0241fa3c60b020dad
- source_armv7h = typst-lsp_armv7-0.3.2::https://github.com/nvarner/typst-lsp/releases/download/v0.3.2/typst-lsp-linux-armhf
+ source_armv7h = typst-lsp-armv7h-0.3.2::https://github.com/nvarner/typst-lsp/releases/download/v0.3.2/typst-lsp-linux-armhf
sha256sums_armv7h = c72ec0e4298ccb0109f26f48af810996d069a5dedfdab56591c38821b8beded8
- source_aarch64 = typst-lsp_aarch64-0.3.2::https://github.com/nvarner/typst-lsp/releases/download/v0.3.2/typst-lsp-linux-arm64
+ source_aarch64 = typst-lsp-aarch64-0.3.2::https://github.com/nvarner/typst-lsp/releases/download/v0.3.2/typst-lsp-linux-arm64
sha256sums_aarch64 = ee6036ea7af1538a3b2cfc9eb50ba81cd6c31e8745d455a5828ed575cbb8b66c
pkgname = typst-lsp-bin
diff --git a/PKGBUILD b/PKGBUILD
index 51defa0d6e13..4401c39be71e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
-# Maintainer: Jake Leahy <jake@lowerCaseLastName.dev
+# Maintainer: Jake Leahy <jake@lowerCaseLastName.dev>
pkgname=typst-lsp-bin
pkgver=0.3.2
-pkgrel=3
-pkgdesc="A brand-new language server for Typst,"
+pkgrel=4
+pkgdesc="A brand-new language server for Typst"
arch=("x86_64" "armv7h" "aarch64")
url="https://github.com/nvarner/typst-lsp"
license=("MIT")
-source_x86_64=("typst-lsp_x86_64-$pkgver::https://github.com/nvarner/typst-lsp/releases/download/v$pkgver/typst-lsp-linux-x64")
-source_armv7h=("typst-lsp_armv7-$pkgver::https://github.com/nvarner/typst-lsp/releases/download/v$pkgver/typst-lsp-linux-armhf")
-source_aarch64=("typst-lsp_aarch64-$pkgver::https://github.com/nvarner/typst-lsp/releases/download/v$pkgver/typst-lsp-linux-arm64")
+source_x86_64=("typst-lsp-x86_64-$pkgver::https://github.com/nvarner/typst-lsp/releases/download/v$pkgver/typst-lsp-linux-x64")
+source_armv7h=("typst-lsp-armv7h-$pkgver::https://github.com/nvarner/typst-lsp/releases/download/v$pkgver/typst-lsp-linux-armhf")
+source_aarch64=("typst-lsp-aarch64-$pkgver::https://github.com/nvarner/typst-lsp/releases/download/v$pkgver/typst-lsp-linux-arm64")
sha256sums_x86_64=('0b3f629ea1350fb03c864661949d338b5d720b5aefbc72f0241fa3c60b020dad')
sha256sums_armv7h=('c72ec0e4298ccb0109f26f48af810996d069a5dedfdab56591c38821b8beded8')
@@ -21,5 +21,5 @@ depends=("glibc" "gcc-libs")
package() {
cd "$srcdir/"
- install -Dm 755 typst-lsp-$pkgver "${pkgdir}/usr/bin/typst-lsp"
+ install -Dm 755 typst-lsp-$CARCH-$pkgver "${pkgdir}/usr/bin/typst-lsp"
}