summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWu, Zhenyu2024-04-02 23:23:39 +0800
committerWu, Zhenyu2024-04-02 23:23:39 +0800
commit8cbc5eb309f221ca02263f733651431fcbf8fe12 (patch)
tree9fc74a0f373f207c6bc77d6aa7c36609b1ce692c
downloadaur-8cbc5eb309f221ca02263f733651431fcbf8fe12.tar.gz
:tada: Initial
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD24
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..823ac6b8886f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = typstfmt
+ pkgdesc = formatter for the Typst language
+ pkgver = 0.2.9
+ pkgrel = 1
+ url = https://github.com/astrale-sharp/typstfmt
+ arch = i686
+ arch = x86_64
+ arch = arm
+ arch = aarch64
+ license = GPL3
+ makedepends = rust
+ source = https://github.com/astrale-sharp/typstfmt/archive/0.2.9.tar.gz
+ sha256sums = fa24ee1705ff5fec4db45e301d38439d0bd3d6d4ee04b280ba997b2f94ba16d9
+
+pkgname = typstfmt
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8a5cafba2b8e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/*
+!/.gitignore
+!/PKGBUILD
+!/.SRCINFO
+!/*.install
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e1059e59145d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# shellcheck shell=bash disable=SC2034,SC2154
+pkgname=typstfmt
+pkgver=0.2.9
+pkgrel=1
+pkgdesc="formatter for the Typst language"
+arch=(i686 x86_64 arm aarch64)
+url=https://github.com/astrale-sharp/$pkgname
+makedepends=(rust)
+license=(GPL3)
+source=("$url/archive/$pkgver.tar.gz")
+sha256sums=('fa24ee1705ff5fec4db45e301d38439d0bd3d6d4ee04b280ba997b2f94ba16d9')
+
+build() {
+ cd "$pkgname-$pkgver" || return 1
+
+ cargo build --release
+}
+
+package() {
+ cd "$pkgname-$pkgver" || return 1
+
+ install -D "target/release/$pkgname" -t "$pkgdir/usr/bin"
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+}