summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTeddyHuang-002024-02-20 11:58:05 -0500
committerTeddyHuang-002024-02-20 11:58:05 -0500
commit761bf39c43c3793e9619b36c573f97888ba58c2b (patch)
treefcee69a14dc5ed7114a4f0d6886224d1e7db8e8e
downloadaur-761bf39c43c3793e9619b36c573f97888ba58c2b.tar.gz
chore: add PKGBUILD, changelog and gitignore
-rw-r--r--.SRCINFO33
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD57
-rw-r--r--typstfmt-bin.changelog45
4 files changed, 137 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a025c0be6e9d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = typstfmt-bin
+ pkgdesc = Basic formatter for the Typst language with a future!
+ pkgver = 0.2.7
+ pkgrel = 1
+ url = https://github.com/astrale-sharp/typstfmt
+ changelog = typstfmt-bin.changelog
+ arch = x86_64
+ arch = aarch64
+ arch = armv7h
+ license = MIT
+ license = Apache-2.0
+ provides = typstfmt
+ conflicts = typstfmt-git
+ source_x86_64 = typstfmt-bin-x86_64-0.2.7.tar.xz::https://github.com/astrale-sharp/typstfmt/releases/download/0.2.7/typstfmt-x86_64-unknown-linux-musl.tar.xz
+ source_x86_64 = LICENSE-APACHE::https://raw.githubusercontent.com/astrale-sharp/typstfmt/main/LICENSE-APACHE
+ source_x86_64 = LICENSE-MIT::https://raw.githubusercontent.com/astrale-sharp/typstfmt/main/LICENSE-MIT
+ sha256sums_x86_64 = ac0ec3a4a9099b9737d2a79b02173c4444835e4bc873eb7ed446fe5f5b87d2f4
+ sha256sums_x86_64 = 3905892d35c90001cd11101d367d4073b773f30fa7ce868748969f4cc1fb24c2
+ sha256sums_x86_64 = 7e302d0694378f3f9584985cf56db84d89b0bcb9f78d04381397349ff50162af
+ source_aarch64 = typstfmt-bin-aarch64-0.2.7.tar.xz::https://github.com/astrale-sharp/typstfmt/releases/download/0.2.7/typstfmt-aarch64-unknown-linux-musl.tar.xz
+ source_aarch64 = LICENSE-APACHE::https://raw.githubusercontent.com/astrale-sharp/typstfmt/main/LICENSE-APACHE
+ source_aarch64 = LICENSE-MIT::https://raw.githubusercontent.com/astrale-sharp/typstfmt/main/LICENSE-MIT
+ sha256sums_aarch64 = 80e990e47c5291c166cb1d5c6f22d17f7779b2644abf2543cef834c8dc3dfc10
+ sha256sums_aarch64 = 3905892d35c90001cd11101d367d4073b773f30fa7ce868748969f4cc1fb24c2
+ sha256sums_aarch64 = 7e302d0694378f3f9584985cf56db84d89b0bcb9f78d04381397349ff50162af
+ source_armv7h = typstfmt-bin-armv7h-0.2.7.tar.xz::https://github.com/astrale-sharp/typstfmt/releases/download/0.2.7/typstfmt-armv7-unknown-linux-musleabi.tar.xz
+ source_armv7h = LICENSE-APACHE::https://raw.githubusercontent.com/astrale-sharp/typstfmt/main/LICENSE-APACHE
+ source_armv7h = LICENSE-MIT::https://raw.githubusercontent.com/astrale-sharp/typstfmt/main/LICENSE-MIT
+ sha256sums_armv7h = 3125f28e14d090f64d0b649060863c34b517ea9b1cc4e3da0e122797d3fe9a0c
+ sha256sums_armv7h = 3905892d35c90001cd11101d367d4073b773f30fa7ce868748969f4cc1fb24c2
+ sha256sums_armv7h = 7e302d0694378f3f9584985cf56db84d89b0bcb9f78d04381397349ff50162af
+
+pkgname = typstfmt-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3b1748476e2f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.tar.*
+LICENSE-*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7fddf0167e82
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Theodore Huang <teddyhuangnan@gmail.com>
+pkgname=typstfmt-bin
+pkgver=0.2.7
+pkgrel=1
+pkgdesc="Basic formatter for the Typst language with a future!"
+arch=("x86_64" "aarch64" "armv7h")
+url="https://github.com/astrale-sharp/typstfmt"
+license=("MIT" "Apache-2.0")
+provides=("typstfmt")
+conflicts=("typstfmt-git")
+changelog=$pkgname.changelog
+source_x86_64=(
+ $pkgname-x86_64-$pkgver.tar.xz::https://github.com/astrale-sharp/typstfmt/releases/download/$pkgver/typstfmt-x86_64-unknown-linux-musl.tar.xz
+ LICENSE-APACHE::https://raw.githubusercontent.com/astrale-sharp/typstfmt/main/LICENSE-APACHE
+ LICENSE-MIT::https://raw.githubusercontent.com/astrale-sharp/typstfmt/main/LICENSE-MIT
+)
+source_aarch64=(
+ $pkgname-aarch64-$pkgver.tar.xz::https://github.com/astrale-sharp/typstfmt/releases/download/$pkgver/typstfmt-aarch64-unknown-linux-musl.tar.xz
+ LICENSE-APACHE::https://raw.githubusercontent.com/astrale-sharp/typstfmt/main/LICENSE-APACHE
+ LICENSE-MIT::https://raw.githubusercontent.com/astrale-sharp/typstfmt/main/LICENSE-MIT
+)
+source_armv7h=(
+ $pkgname-armv7h-$pkgver.tar.xz::https://github.com/astrale-sharp/typstfmt/releases/download/$pkgver/typstfmt-armv7-unknown-linux-musleabi.tar.xz
+ LICENSE-APACHE::https://raw.githubusercontent.com/astrale-sharp/typstfmt/main/LICENSE-APACHE
+ LICENSE-MIT::https://raw.githubusercontent.com/astrale-sharp/typstfmt/main/LICENSE-MIT
+)
+# checksum generate with 'makepkg -g'
+sha256sums_x86_64=('ac0ec3a4a9099b9737d2a79b02173c4444835e4bc873eb7ed446fe5f5b87d2f4'
+ '3905892d35c90001cd11101d367d4073b773f30fa7ce868748969f4cc1fb24c2'
+ '7e302d0694378f3f9584985cf56db84d89b0bcb9f78d04381397349ff50162af')
+sha256sums_aarch64=('80e990e47c5291c166cb1d5c6f22d17f7779b2644abf2543cef834c8dc3dfc10'
+ '3905892d35c90001cd11101d367d4073b773f30fa7ce868748969f4cc1fb24c2'
+ '7e302d0694378f3f9584985cf56db84d89b0bcb9f78d04381397349ff50162af')
+sha256sums_armv7h=('3125f28e14d090f64d0b649060863c34b517ea9b1cc4e3da0e122797d3fe9a0c'
+ '3905892d35c90001cd11101d367d4073b773f30fa7ce868748969f4cc1fb24c2'
+ '7e302d0694378f3f9584985cf56db84d89b0bcb9f78d04381397349ff50162af')
+
+build() {
+ if [ $CARCH == "x86_64" ]; then
+ mv "$srcdir/typstfmt-x86_64-unknown-linux-musl/" "$srcdir/$pkgname-$pkgver/"
+ elif [ $CARCH == "aarch64" ]; then
+ mv "$srcdir/typstfmt-aarch64-unknown-linux-musl/" "$srcdir/$pkgname-$pkgver/"
+ elif [ $CARCH == "armv7h" ]; then
+ mv "$srcdir/typstfmt-armv7-unknown-linux-musleabi/" "$srcdir/$pkgname-$pkgver/"
+ else
+ echo "Unknown architecture: $CARCH"
+ exit 1
+ fi
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver/"
+ install -Dm755 typstfmt "$pkgdir/usr/bin/typstfmt"
+ cd "$srcdir/"
+ install -Dm644 LICENSE-APACHE "$pkgdir/usr/share/licenses/$pkgname/LICENSE-APACHE"
+ install -Dm644 LICENSE-MIT "$pkgdir/usr/share/licenses/$pkgname/LICENSE-MIT"
+}
diff --git a/typstfmt-bin.changelog b/typstfmt-bin.changelog
new file mode 100644
index 000000000000..9203430f8c24
--- /dev/null
+++ b/typstfmt-bin.changelog
@@ -0,0 +1,45 @@
+# Latest
+
+# Release 0.2.7
+
+- String literal preserved in math mode @monaqa
+- fix indent problems with raw code (hacky)
+- global config: renamed `default-config` to `typstfmt` @Andrew Voynov
+- improves max_len checking (first line of node still doesn't respect it)
+- Implement Math Block Align @taooceros
+
+# Release 0.2.6
+
+- remove header in stdout unless there is a panic
+- Add a flag to print the path of the global config file
+- If no config file exists, read a global configuration file
+- Optimized show_all.sh and made it POSIX-compliant
+- Removed "-config" from config file name
+- remove trailing comma logic in math fmt
+- compat add --stdout
+
+# Release 0.2.5
+
+- one less indent for trailing blocks
+- prints "up to date" if the file wasn't changed
+...
+
+
+# Release 0.2.1#1817538
+- adds conditional formatting, nested if else etc
+- fix a bug where push_raw_indent was trimming lines
+- improve behavior of formatting arguments in a breaking manner
+- Some cleanups, nitpicks etc.
+
+# Release 0.2.0
+
+Features:
+- Linewrap for content
+- On Off feature
+- Config Files
+- Enum and List formatting
+- Codeblock formatting
+- Many comments handling fixes
+- Args breaking in function calls with trailing comma
+- Parenthesized formatting
+- Binop formatting \ No newline at end of file