summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2016-05-16 06:13:01 -0700
committerMike Swanson2016-05-16 06:13:01 -0700
commita4d8f37ec99952b2cee87f79dc02f50238dee41e (patch)
tree0d869e55a047dcbf8b4ef3dcf2cab16a345652e5
downloadaur-a4d8f37ec99952b2cee87f79dc02f50238dee41e.tar.gz
New tyrquake-git package
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD41
-rw-r--r--tyrquake.install6
4 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e6104ef7306e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Mon May 16 13:11:36 UTC 2016
+pkgbase = tyrquake-git
+ pkgdesc = A conservative Quake port
+ pkgver = 0.61.r1226.0ca7766
+ pkgrel = 1
+ url = http://disenchant.net/tyrquake/
+ install = tyrquake.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = sdl2
+ provides = tyrquake
+ conflicts = tyrquake
+ source = git://disenchant.net/tyrquake
+ sha256sums = SKIP
+
+pkgname = tyrquake-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3489abe5e214
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.pkg.tar*
+*.src.tar*
+*.gz
+src
+pkg
+/tyrquake
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c202c0b3045
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Mike Swanson <mikeonthecomputer@gmail.com>
+
+pkgname=tyrquake-git
+pkgver=0.61.r1226.0ca7766
+pkgrel=1
+pkgdesc="A conservative Quake port"
+arch=('i686' 'x86_64')
+url="http://disenchant.net/tyrquake/"
+license=(GPL2)
+depends=(sdl2)
+makedepends=(git)
+conflicts=(tyrquake)
+provides=(tyrquake)
+install=tyrquake.install
+source=("git://disenchant.net/tyrquake")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname/-git/}"
+ local version="$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+ printf %s "${version##v}"
+}
+
+build() {
+ cd "${pkgname/-git/}"
+
+ [ "$CARCH" = "i686" ] && _asm=Y || _asm=N
+
+ make QBASEDIR=/usr/share/games/quake \
+ USE_X86_ASM=$_asm \
+ OPTIMIZED_CFLAGS=N \
+ USE_SDL=Y \
+ STRIP=true
+}
+
+package() {
+ cd "${pkgname/-git/}"
+
+ install -d "$pkgdir/usr/bin"
+ install bin/tyr-* "$pkgdir/usr/bin"
+}
diff --git a/tyrquake.install b/tyrquake.install
new file mode 100644
index 000000000000..10c7b4650920
--- /dev/null
+++ b/tyrquake.install
@@ -0,0 +1,6 @@
+post_install() {
+ cat <<EOF
+You need the Quake 1 data files to play.
+Copy the "id1" directory to /usr/share/games/quake
+EOF
+}