summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNiels Martignène2018-05-10 10:23:45 +0200
committerNiels Martignène2018-05-10 10:23:45 +0200
commit2f3d8efb678030541487abd63c639730d67a371c (patch)
tree5516cedc4aa0f67098d9d84737fe1bdaf2c77692
downloadaur-2f3d8efb678030541487abd63c639730d67a371c.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD38
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..006bc3a53207
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = tytools
+ pkgdesc = GUI and command-line tools to manage Teensy devices
+ pkgver = 0.8.8
+ pkgrel = 1
+ url = http://github.com/Koromix/tytools
+ arch = x86_64
+ arch = i686
+ license = custom:Unlicense
+ makedepends = git
+ makedepends = imagemagick
+ depends = teensyduino
+ depends = libudev.so
+ depends = qt5-base
+ provides = tytools
+ provides = ty
+ conflicts = ty
+ conflicts = teensytools
+ source = https://github.com/Koromix/tytools/archive/v0.8.8.tar.gz
+ sha256sums = ce9dfc7eb0db2982b3a3de5f3b20851baf107e9c3c139a08e48afd4af123c0ab
+
+pkgname = tytools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a8a1ab1e7e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Niels Martignène <niels.martignene@gmail.com>
+
+pkgname=tytools
+pkgver=0.8.8
+pkgrel=1
+pkgdesc="GUI and command-line tools to manage Teensy devices"
+arch=('x86_64' 'i686')
+url="http://github.com/Koromix/tytools"
+license=('custom:Unlicense')
+depends=('teensyduino' 'libudev.so' 'qt5-base')
+makedepends=('git' 'imagemagick')
+provides=('tytools' 'ty')
+conflicts=('ty' 'teensytools')
+source=("https://github.com/Koromix/tytools/archive/v${pkgver}.tar.gz")
+sha256sums=('ce9dfc7eb0db2982b3a3de5f3b20851baf107e9c3c139a08e48afd4af123c0ab')
+
+build() {
+ cd "tytools-${pkgver}"
+
+ cmake -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "tytools-${pkgver}"
+
+ make install DESTDIR="${pkgdir}"
+
+ for size in 16 32 48 256; do
+ mkdir -p "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps"
+ convert -resize "${size}x${size}" resources/images/tycommander.png \
+ "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps/tycommander.png"
+ convert -resize "${size}x${size}" resources/images/tyupdater.png \
+ "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps/tyupdater.png"
+ done
+
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/tytools-git/LICENSE.txt"
+}