summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzoe2016-02-12 23:46:34 +0100
committerzoe2016-02-12 23:46:34 +0100
commit0c339bf30a6793e5306ac685a6a803e817914c3e (patch)
tree758b0e2dea662a545ea2a066741e1961b622a300
downloadaur-0c339bf30a6793e5306ac685a6a803e817914c3e.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD52
-rw-r--r--u-gotme.desktop12
-rw-r--r--u-gotme.install12
-rw-r--r--u-gotme48.pngbin0 -> 6373 bytes
5 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..be85bd7128c6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Fri Feb 12 22:44:56 UTC 2016
+pkgbase = u-gotme
+ pkgdesc = Software to download and upload tracks, routes and waypoints to the I-gotU series of GPS loggers : GT-800, GT-800Pro, GT-820Pro and GT-900Pro.
+ pkgver = 2.3
+ pkgrel = 1
+ url = http://u-gotme.deepocean.net/
+ install = u-gotme.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = java-runtime
+ source = http://blog.studioblueplanet.net/wp-content/files/u-gotme/u-gotme-version2.3.zip
+ source = u-gotme48.png
+ source = u-gotme.desktop
+ source = u-gotme.install
+ md5sums = d7458b46e93b5ee386c50ae0df35bfad
+ md5sums = 06558d55015c55eb5a518603fefe48f7
+ md5sums = 2c326c52127c7aa8522e450b50b1b061
+ md5sums = e264102987e6e1d75310da548b9ed395
+
+pkgname = u-gotme
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..11a99718c27a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: zoe <chp321@gmail.com>
+
+pkgname=u-gotme
+pkgver=2.3
+pkgrel=1
+pkgdesc="Software to download and upload tracks, routes and waypoints to the I-gotU series of GPS loggers : GT-800, GT-800Pro, GT-820Pro and GT-900Pro."
+arch=('i686' 'x86_64')
+if test "$CARCH" == x86_64; then
+ _arch="64"
+fi
+if test "$CARCH" == i686; then
+ _arch="32"
+fi
+url="http://u-gotme.deepocean.net/"
+license=('GPL')
+depends=('java-runtime')
+install=${pkgname}.install
+source=("http://blog.studioblueplanet.net/wp-content/files/${pkgname}/${pkgname}-version${pkgver}.zip"
+ "${pkgname}48.png" "${pkgname}.desktop" "${pkgname}.install")
+md5sums=(
+'d7458b46e93b5ee386c50ae0df35bfad'
+'06558d55015c55eb5a518603fefe48f7'
+'2c326c52127c7aa8522e450b50b1b061'
+'e264102987e6e1d75310da548b9ed395')
+
+
+package() {
+ mkdir -p ${pkgdir}/usr/share/java/
+ mv ${srcdir}/${pkgname}/linux_${_arch}/ ${pkgdir}/usr/share/java/
+ cd ${pkgdir}/usr/share/java/linux_${_arch}
+ if test "$CARCH" == x86_64; then
+ mv start64 ${pkgname}
+ fi
+ if test "$CARCH" == i686; then
+ mv start ${pkgname}
+ fi
+ sed -i '2i\cd /usr/share/java/u-gotme/' ${pkgname}
+ chmod 755 ${pkgname}
+ cd ..
+ mv linux_${_arch} ${pkgname}
+ cp ${srcdir}/${pkgname}/INSTALL_AND_RUN.TXT ${pkgdir}/usr/share/java/${pkgname}/INSTALL_AND_RUN.TXT
+ cp ${srcdir}/${pkgname}/README.TXT ${pkgdir}/usr/share/java/${pkgname}/README.TXT
+
+# install icon
+ install -DTm644 ${srcdir}/${pkgname}48.png ${pkgdir}/usr/share/icons/hicolor/48x48/apps/${pkgname}48.png
+
+# install file.desktop
+ install -DTm644 ${srcdir}/${pkgname}.desktop ${pkgdir}/usr/share/applications/${pkgname}.desktop
+
+ mkdir -p ${pkgdir}/usr/bin/
+ ln -s ${pkgdir}/usr/share/java/${pkgname}/${pkgname} ${pkgdir}/usr/bin/${pkgname}
+} \ No newline at end of file
diff --git a/u-gotme.desktop b/u-gotme.desktop
new file mode 100644
index 000000000000..5c7c241daaaa
--- /dev/null
+++ b/u-gotme.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Exec=u-gotme
+Icon=/usr/share/icons/hicolor/48x48/apps/u-gotme48.png
+Terminal=false
+Name=u-gotme
+Comment=Download and upload tracks, routes and waypoints to the I-gotU series of GPS loggers
+GenericName=u-gotme
+GenericName[fr]=u-gotme
+X-KDE-StartupNotify=true
+Categories=Science;Maps;Geography;Education;
diff --git a/u-gotme.install b/u-gotme.install
new file mode 100644
index 000000000000..02d2e3036201
--- /dev/null
+++ b/u-gotme.install
@@ -0,0 +1,12 @@
+
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+} \ No newline at end of file
diff --git a/u-gotme48.png b/u-gotme48.png
new file mode 100644
index 000000000000..b6660cc3aef3
--- /dev/null
+++ b/u-gotme48.png
Binary files differ