summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Patton2018-07-27 13:16:46 +1000
committerMike Patton2018-07-27 13:16:46 +1000
commitac5e15326a576afce7e169c36ebba27cad413e49 (patch)
tree7389a034c62a7bac3f5afe09c5057d8352df3ea9
downloadaur-ac5e15326a576afce7e169c36ebba27cad413e49.tar.gz
Initial commit to AUR.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb779c21fd48
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = u2f-hidraw-policy
+ pkgdesc = Another UDEV rule for U2F devices.
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://github.com/amluto/u2f-hidraw-policy
+ arch = x86_64
+ license = LGPL2.1
+ depends = libsystemd
+ conflicts = libu2f-host
+ conflicts = libu2f-host-git
+ conflicts = u2f-udev-rules-git
+ source = git+https://github.com/amluto/u2f-hidraw-policy.git
+ md5sums = SKIP
+
+pkgname = u2f-hidraw-policy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1050beb1cf98
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Mike Patton <mike@myowncyber.space>
+pkgname=u2f-hidraw-policy
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="Another UDEV rule for U2F devices."
+arch=('x86_64')
+url="https://github.com/amluto/u2f-hidraw-policy"
+license=('LGPL2.1')
+depends=('libsystemd')
+conflicts=('libu2f-host' 'libu2f-host-git' 'u2f-udev-rules-git')
+source=("git+https://github.com/amluto/u2f-hidraw-policy.git")
+
+build() {
+ cd "$pkgname"
+ make
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="$pkgdir/" install
+}
+md5sums=('SKIP')